Bug 1128476 - OS page displays description under name column
Summary: OS page displays description under name column
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 18:16 UTC by sthirugn@redhat.com
Modified: 2019-09-26 13:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:43:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
OS desc displayed instead of name (77.44 KB, image/png)
2014-08-10 18:17 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description sthirugn@redhat.com 2014-08-10 18:16:05 UTC
Description of problem:
OS page displays description under the name column

Version-Release number of selected component (if applicable):
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a new OS with name = 'testos' and description = 'This is not name but Description'
2. Go back to the OS summary page

Actual results:
Observe that Description is displayed under name column (see screenshot)

Expected results:
Name column should display the OS name and not description

Additional info:

Comment 1 sthirugn@redhat.com 2014-08-10 18:17:00 UTC
Created attachment 925544 [details]
OS desc displayed instead of name

Comment 3 Dominic Cleal 2014-08-11 07:21:21 UTC
This is by design, as the "Name" is typically a Facter string and doesn't show trademarks etc correctly.

Comment 4 sthirugn@redhat.com 2014-08-11 13:24:50 UTC
Disagree.  This will confuse the user (and it did confuse me) when I was trying to search for the OS name. It took a while for me to understand that description is being displayed under OS column.

Comment 5 Dominic Cleal 2014-08-11 15:31:33 UTC
Cannot make this change without reverting the use case from bug #1023089 which is deemed higher priority, unless the column is renamed to something else.

Comment 8 Bryan Kearney 2015-12-18 21:18:32 UTC
I see that the column header in 1.11 is now "Title". I think this is a fair compromise, and I am moving this to ON_QA to verify.

Comment 9 sthirugn@redhat.com 2016-03-18 19:13:50 UTC
Title seems to be fair.  Thank you Bryan and Dominic.

Verified in Satellite 6.2.0-beta-snap4

Comment 12 errata-xmlrpc 2016-07-27 08:43:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.