Bug 1128493 - [RFE] Making fencing operations soft and configurable
Summary: [RFE] Making fencing operations soft and configurable
Keywords:
Status: CLOSED DUPLICATE of bug 1158861
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.6.0
Assignee: Eli Mesika
QA Contact:
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 20:45 UTC by Eli Mesika
Modified: 2016-02-10 19:38 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-06 08:57:03 UTC
oVirt Team: Infra
sherold: Triaged+


Attachments (Terms of Use)
mockup: proposed design for Cluster Fencing Policy (27.03 KB, image/png)
2014-08-18 22:13 UTC, Einav Cohen
no flags Details

Description Eli Mesika 2014-08-10 20:45:56 UTC
Description of problem:
[RFE] Making fencing operations soft and configurable

As we are adding more and more fencing types and steps like 
a) soft fencing
b) kdump fencing
c) hard fencing (reboot the machine using it PM card)
d) storage fencing (future)

There is a need to introduce a Fencing Chain mechanism that will be responsible of :

1) Which fencing steps are active.
2) What is the order in which fencing steps are executed.

The Fencing Chain should have a default that maps to the current implementation and this default may be overridden by each Cluster.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Einav Cohen 2014-08-18 18:49:36 UTC
Eli - are there more details anywhere for this feature (e.g. ovirt wiki page)? we would love to help out in designing the GUI for that, if relevant. thanks.

Comment 2 Eli Mesika 2014-08-18 21:18:06 UTC
(In reply to Einav Cohen from comment #1)
> Eli - are there more details anywhere for this feature (e.g. ovirt wiki
> page)? we would love to help out in designing the GUI for that, if relevant.
> thanks.

Einav
This will surely have a design like any new feature
I will try to elaborate more on that 

Currently we have few fencing stages 
Soft-Fencing (i.e. restarting VDSM)
Kdump fencing (i.e. wait for kdump to complete writing the dump before reboot)
Hard fencing (restart using the PM card)

We want the Fencing Policy new TAB in Cluster New/Edit to have an option to define which stages are active and in which order

Solution should be generic such that other fencing stages that might be introduced in next versions can be integrated easily (by only changing the config entry od available stages)

I hope that this shades more light on this RFE and I will CC you on the design page when I will get to it

Comment 3 Einav Cohen 2014-08-18 22:13:27 UTC
Created attachment 928080 [details]
mockup: proposed design for Cluster Fencing Policy

Comment 4 Einav Cohen 2014-08-18 22:18:35 UTC
Many Thanks, Eli - your explanation was extremely helpful. 
I think that we need something like attachment 928080 [details]. 

@Eldan/Liz - thoughts? do we have a PatternFly pattern for such use-case?

Comment 5 Eldan Hildesheim 2014-08-19 11:35:49 UTC
I Spoke with Eli,
Seems like not all fencing order combinations are possible, which means that the possible option are not factorial, but Eli still has to check this out.
As I understood, there could be 1 more fencing option which means total of 4.
If the above is true, I recommend having a drop down option with all combinations inside it (~5 combinations).
In case the above is not true - all the combinations are available, I would change a bit Einav sketch and instead of dragging item from right to left, I would enable them with a checkbox, since there are only 4 and it doesn't justify a shuttle (right left drag/assign widget). The change order will need to be added then, like Einav did.
E.

Comment 6 Einav Cohen 2014-08-19 18:53:11 UTC
(In reply to Eldan Hildesheim from comment #5)
> I Spoke with Eli,
> Seems like not all fencing order combinations are possible, which means that
> the possible option are not factorial, but Eli still has to check this out.
> As I understood, there could be 1 more fencing option which means total of 4.
> If the above is true, I recommend having a drop down option with all
> combinations inside it (~5 combinations).
> In case the above is not true - all the combinations are available, I would
> change a bit Einav sketch and instead of dragging item from right to left, I
> would enable them with a checkbox, since there are only 4 and it doesn't
> justify a shuttle (right left drag/assign widget). The change order will
> need to be added then, like Einav did.
> E.

sounds good - thanks, Eldan. 
Please keep following up with Eli, let me/Liz know if any additional assistance is needed. 
[@Liz - if you have any ideas/comments, please share]

Comment 7 Eldan Hildesheim 2014-09-01 09:14:07 UTC
Eli, please let me know when you have any decisions regarding the Policy combinations.

Comment 8 Eli Mesika 2014-09-15 13:00:27 UTC
(In reply to Eldan Hildesheim from comment #7)
> Eli, please let me know when you have any decisions regarding the Policy
> combinations.

RFE is entering  design phase, will update info when available

Comment 9 Oved Ourfali 2015-04-06 08:57:03 UTC
Closing as duplicate of Bug 1158861, in which we will do many enhancements in the fencing flow, both on backend and UI.

*** This bug has been marked as a duplicate of bug 1158861 ***


Note You need to log in before you can comment on or make changes to this bug.