Bug 1158861 - [RFE] - Fencing refactoring
Summary: [RFE] - Fencing refactoring
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Perina
QA Contact: Petr Matyáš
URL:
Whiteboard:
: 1128493 (view as bug list)
Depends On: 1182510 1257575 1257610
Blocks: 1255229
TreeView+ depends on / blocked
 
Reported: 2014-10-30 12:04 UTC by Martin Perina
Modified: 2019-04-28 13:30 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:50:19 UTC
oVirt Team: Infra
Target Upstream Version:
sherold: Triaged+
ylavi: testing_beta_priority+


Attachments (Terms of Use)
Last UX plan for the Power Management (366.79 KB, image/tiff)
2015-04-15 08:55 UTC, Eldan Hildesheim
no flags Details
Last sketches for Power Management (272.93 KB, image/png)
2015-04-15 09:02 UTC, Eldan Hildesheim
no flags Details
UX changes - Host Availability tab (32.00 KB, image/png)
2015-04-15 09:03 UTC, Martin Perina
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Martin Perina 2014-10-30 12:04:25 UTC
The goal is to refactor current fencing flow to make it more transparent and configurable. The main goals will be:

  1) Define unqiue interface to all fencing flow steps (SSH Soft Fencing, Kdump detection, hard fencing, ...)
  2) Make each step easily configurable
  3) Refactoring fencing flow code to make more understandable

More info will be posted later to feature page.

Comment 1 Oved Ourfali 2015-04-06 08:57:03 UTC
*** Bug 1128493 has been marked as a duplicate of this bug. ***

Comment 2 Eldan Hildesheim 2015-04-15 08:55:41 UTC
Created attachment 1014630 [details]
Last UX plan for the Power Management

Comment 3 Eldan Hildesheim 2015-04-15 09:02:01 UTC
Created attachment 1014643 [details]
Last sketches for Power Management

Comment 4 Martin Perina 2015-04-15 09:03:47 UTC
Created attachment 1014644 [details]
UX changes - Host Availability tab

Hi Eldan,

we will add only Host Availability tab in this bug. The changes in Power Management tab are covered in BZ1198628.

So I replaced your attachment with correct one proposal.

Thanks

Martin

Comment 8 Petr Matyáš 2015-08-26 12:15:28 UTC
When I stop network service on my host, engine is unable to automatically fence the host. Although it can restart the host if I restart it through power management manually.

Comment 10 Yaniv Lavi 2015-08-27 12:31:11 UTC
Please do not fail RFE, please open separate bug and block this one for the tracking.

Comment 11 Martin Perina 2015-10-26 08:44:33 UTC
Documentation changes are already covered by BZ1255229

Comment 13 errata-xmlrpc 2016-03-09 20:50:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.