Bug 1128766 - nm-applet leaks memory
Summary: nm-applet leaks memory
Keywords:
Status: CLOSED DUPLICATE of bug 1314976
Alias: None
Product: Fedora
Classification: Fedora
Component: network-manager-applet
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1114480 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 14:05 UTC by Zdenek Kabelac
Modified: 2016-03-11 09:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-11 09:59:30 UTC


Attachments (Terms of Use)
smaps of nm-applet (277.67 KB, text/plain)
2014-08-11 14:05 UTC, Zdenek Kabelac
no flags Details

Description Zdenek Kabelac 2014-08-11 14:05:53 UTC
Created attachment 925760 [details]
smaps of nm-applet

Description of problem:

During couple days of usage (uptime of 13 days) my nm-applet has grown to 650MB which is way to much for an applet.

  PID PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
 1053 20   0 2194148 650228  26068 S  15,5 16,5   9:27.21 nm-applet

Attached is smaps of nm-applet process - which shows the major portion is consumed by heap.

If the maintainer wants - I may probably use it through valgrind...

Version-Release number of selected component (if applicable):
network-manager-applet-0.9.9.0-12.git20140424.fc21.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Zdenek Kabelac 2014-08-13 17:46:55 UTC
*** Bug 1114480 has been marked as a duplicate of this bug. ***

Comment 2 Zdenek Kabelac 2014-08-13 17:52:44 UTC
See the created attachment 926548 [details] for bug 1129818 for the memory leaks.

Comment 3 Jaroslav Reznik 2015-03-03 16:11:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 4 Thomas Lehmann 2015-05-27 22:13:03 UTC
I can confirm this bug in F21.

- The memory increases (~10MB) each time the password dialog appears, asking for the WPA2 personal login
- It does not increase when disconnecting
- It does not increase when confirming the password
- It does only increase ~1KB when the connection is has just established

The package is network-manager-applet-0.9.10.3-1.git20150511.36c8684.fc21.x86_64

Comment 5 Thomas Lehmann 2015-05-28 17:41:37 UTC
- It does not increase when a network has a saved password and connects without entering the password.

Comment 6 Fedora Admin XMLRPC Client 2015-10-14 14:50:07 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Zdenek Kabelac 2016-03-11 09:59:30 UTC
Looking at the reported leaks - and considering my newly opened Bug #1314976  which is now marked as fixed - I'm considering it as being a duplicate.

*** This bug has been marked as a duplicate of bug 1314976 ***


Note You need to log in before you can comment on or make changes to this bug.