Bug 1128772 - Authentication failure message is not clear on remote agent installation
Summary: Authentication failure message is not clear on remote agent installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ER02
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: JON3-30, PRODMGT-542
TreeView+ depends on / blocked
 
Reported: 2014-08-11 14:14 UTC by Jeeva Kandasamy
Modified: 2014-12-11 14:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:01:24 UTC
Type: Bug


Attachments (Terms of Use)
remote-agent-install-auth-failure-message (82.74 KB, image/jpeg)
2014-08-11 14:14 UTC, Jeeva Kandasamy
no flags Details
remote-agent-install-auth-failure-message-verified (69.34 KB, application/octet-stream)
2014-09-10 11:36 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-08-11 14:14:36 UTC
Created attachment 925774 [details]
remote-agent-install-auth-failure-message

Description of problem:
Authentication failure message is not clear on remote agent installation.
For authentication it says "An SSH connection error occurred.: com.jcraft.jsch.JSchException:Auth cancel".

Should be a user friendly message. Currently it looks like developer error message.

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.DR01
Build Number : 6468454:dda0a47
GWT Version : 2.5.0
SmartGWT Version : 3.0p

How reproducible:
always

Steps to Reproduce:
1. Navigate to 'Administration->Topology->Agents->New'
2. Enter wrong password for SSH authentication
3. Click on 'Update Status'


Additional info: Screen shot is attached.

Comment 1 Michael Burman 2014-08-28 20:53:34 UTC
Fixed in master:

commit 66effaa0b473c133c4f1e667b0bea4436d85cbff
Merge: 7bef780 c1fdabc
Author: John Mazzitelli <mazz@redhat.com>
Date:   Thu Aug 28 16:17:59 2014 -0400

    Merge pull request #114 from burmanm/remote_agent
    
    Modify remote agent install UI and make userfriendlier error messages

commit c1fdabc180a8b63d43813d4640b24b686f2aad44
Author: Michael Burman <miburman@redhat.com>
Date:   Wed Aug 20 17:29:05 2014 +0300

    [BZ 1131495] Refactor SSHInstallUtility to catch error messages and throw exceptions if operations fail, instead of returning just Failed te
    
    [BZ 1132051] Catch scp errors when installing to get proper error message for missing permissions.
    
    [BZ 1128772] Catch some basic error messages and create a friendlier layout for them
    
    [BZ 1128779] After the agent has been installed, refresh the UI to show only relevant information.
    
    [BZ 1128782] While installing, show window which indicates the installation is running

Comment 2 Jay Shaughnessy 2014-08-29 17:58:40 UTC
This is handled by the same cherry-pick done for Bug 1132051.

Release/jon3.3.x commit 83f133d17ce4eb377fc2b398b109c41da3ef6c6e
Author: John Mazzitelli <mazz@redhat.com>
Date:   Thu Aug 28 16:17:59 2014 -0400

    Merge pull request #114 from burmanm/remote_agent
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>

Comment 3 Simeon Pinder 2014-09-03 20:31:46 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194

Comment 4 Jeeva Kandasamy 2014-09-10 11:36:40 UTC
Created attachment 936109 [details]
remote-agent-install-auth-failure-message-verified

Version:
JBoss Operations Network	
Version : 3.3.0.ER02
Build Number : 4fbb183:7da54e2
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 31.0


Note You need to log in before you can comment on or make changes to this bug.