Bug 1131495 - Remote Agent installation exception is not clear if the user does not have write permission on the selected directory
Summary: Remote Agent installation exception is not clear if the user does not have wr...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ER02
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On: 1132051
Blocks: JON3-30, PRODMGT-542
TreeView+ depends on / blocked
 
Reported: 2014-08-19 12:24 UTC by Jeeva Kandasamy
Modified: 2014-12-11 14:02 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:02:25 UTC


Attachments (Terms of Use)
error message on GUI (84.75 KB, image/jpeg)
2014-08-19 12:24 UTC, Jeeva Kandasamy
no flags Details
permission error message on GUI - verified (50.60 KB, application/octet-stream)
2014-09-10 11:41 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-08-19 12:24:17 UTC
Created attachment 928343 [details]
error message on GUI

Description of problem:
Remote Agent installation exception is not clear if the user does not have write permission on the selected directory

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.DR01
Build Number : 6468454:dda0a47
GWT Version : 2.5.0
SmartGWT Version : 3.0p

How reproducible:
always

Steps to Reproduce:
1. Install a remote agent where is ssh user does not have write permission on remote directory.

Actual results:
Throwing exception as expected, but could not understand the actual reason with the error message.
Current error message "(TypeError) : Cannot read property 'value_0' of null"

Expected results:
Should report user understandable error message.

Additional info: Screen shot is attached

Comment 1 Michael Burman 2014-08-20 12:43:00 UTC
What I get is different. First "Agent installation successful" and then "Global uncaught exception":

Root Cause :	
(TypeError) : result.confirmedAgentConnection is null
Detail :	

com.google.gwt.core.client.JavaScriptException:(TypeError) : result.confirmedAgentConnection is null

What happens is that there's no Exception thrown at all from the libraries:

15:41:22,304 INFO  [org.rhq.enterprise.server.install.remote.SSHInstallUtility] (http-/0.0.0.0:7080-37) Copying agent binary update distribution file to [localhost]...
15:41:22,322 INFO  [stdout] (http-/0.0.0.0:7080-37) scp: /home/agent/new-agent: Permission denied

Comment 2 Michael Burman 2014-08-28 20:54:00 UTC
Fixed in master:

commit 66effaa0b473c133c4f1e667b0bea4436d85cbff
Merge: 7bef780 c1fdabc
Author: John Mazzitelli <mazz@redhat.com>
Date:   Thu Aug 28 16:17:59 2014 -0400

    Merge pull request #114 from burmanm/remote_agent
    
    Modify remote agent install UI and make userfriendlier error messages

commit c1fdabc180a8b63d43813d4640b24b686f2aad44
Author: Michael Burman <miburman@redhat.com>
Date:   Wed Aug 20 17:29:05 2014 +0300

    [BZ 1131495] Refactor SSHInstallUtility to catch error messages and throw exceptions if operations fail, instead of returning just Failed te
    
    [BZ 1132051] Catch scp errors when installing to get proper error message for missing permissions.
    
    [BZ 1128772] Catch some basic error messages and create a friendlier layout for them
    
    [BZ 1128779] After the agent has been installed, refresh the UI to show only relevant information.
    
    [BZ 1128782] While installing, show window which indicates the installation is running

Comment 3 Jay Shaughnessy 2014-08-29 17:58:03 UTC
This is handled by the same cherry-pick done for Bug 1132051.

Release/jon3.3.x commit 83f133d17ce4eb377fc2b398b109c41da3ef6c6e
Author: John Mazzitelli <mazz@redhat.com>
Date:   Thu Aug 28 16:17:59 2014 -0400

    Merge pull request #114 from burmanm/remote_agent
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>

Comment 4 Simeon Pinder 2014-09-03 20:31:25 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194

Comment 5 Jeeva Kandasamy 2014-09-10 11:41:40 UTC
Created attachment 936112 [details]
permission error message on GUI - verified

Version:
JBoss Operations Network	
Version : 3.3.0.ER02
Build Number : 4fbb183:7da54e2
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 31.0


Note You need to log in before you can comment on or make changes to this bug.