Bug 1128846 - Unexpected error: Cartridge attempted to override the following gear environment variables: JENKINS_USERNAME, JENKINS_PASSWORD
Summary: Unexpected error: Cartridge attempted to override the following gear environm...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Pod
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: libra bugs
URL:
Whiteboard:
: 1130719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 15:54 UTC by ajjgabriel
Modified: 2015-05-15 00:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-18 16:50:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unexpected error: Cartridge attempted to override the following gear environment variables: JENKINS_USERNAME, JENKINS_PASSWORD (184.27 KB, image/png)
2014-08-11 15:54 UTC, ajjgabriel
no flags Details

Description ajjgabriel 2014-08-11 15:54:51 UTC
Created attachment 925825 [details]
Unexpected error: Cartridge attempted to override the following gear environment variables: JENKINS_USERNAME, JENKINS_PASSWORD

Description of problem:
Whenever I try to add Jenkins Cartridge, it will prompt me error (I think is only for my account)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Click on my app
2. Click on Enable Jenkins
3. Add Jenkins

Actual results:
Prompt Error: Unexpected error: Cartridge attempted to override the following gear environment variables: JENKINS_USERNAME, JENKINS_PASSWORD

Expected results:
Jenkins Successfully Added with Username and Password


Additional info:

Comment 1 Ben Parees 2014-08-11 15:58:31 UTC
Andy is this the same as the other jenkins issue you looked into that appeared to be a broker issue? (leftover env vars in mongo)

Comment 2 Andy Goldstein 2014-08-11 16:04:19 UTC
@Ben yes, for some reason it looks like creating Jenkins apps doesn't always complete successfully (perhaps especially for small gears?) and when the rollback happens, it doesn't roll back domain env vars or domain ssh keys. (See bug #1126826.)

I think there are 2 issues:

1) Sometimes Jenkins apps fail to create. This may happen more frequently with small gears.

2) Rollback doesn't delete domain env vars or ssh keys.

Comment 3 ajjgabriel 2014-08-11 16:31:33 UTC
Is there anyway other way to go about creating my jenkins ?
Or could someone help me to get rid of the env var?

Comment 4 Andy Goldstein 2014-08-15 13:36:50 UTC
Sorry for the delay in replying. Do you have any other applications in your domain? If not, you can try to delete your domain and recreate it, which will clear the stuck env vars.

Comment 5 Andy Goldstein 2014-08-15 14:12:34 UTC
Reassigning to broker team

Comment 6 Ben Parees 2014-08-16 22:26:56 UTC
*** Bug 1130719 has been marked as a duplicate of this bug. ***

Comment 7 ajjgabriel 2014-08-17 02:10:24 UTC
Thanks! The deletion of the domain worked! :D

Comment 8 Abhishek Gupta 2014-08-18 16:40:04 UTC
Fixed with --> https://github.com/openshift/origin-server/pull/5717

Comment 9 Jianwei Hou 2014-08-19 02:32:23 UTC
Verified on devenv_5089

Steps:
1. Create domain
2. Create jenkins app, stop ruby193-mcollective while the creation is underway, this makes the creation fail and all pending ops will rollback.
3. Start ruby193-mcollective
4. Clear pending ops
5. Make sure the jenkins env vars are cleaned up by querying domain records in datastore
6. Create another jenkins app

Result:
App is cleaned up, the env_vars are cleaned up from user domains. New jenkins app created successfully.

Comment 10 Andy Grimm 2014-09-02 16:06:06 UTC
Do we have a script going out as part of this to fix all currently-impacted users?

Comment 11 Abhishek Gupta 2014-09-08 23:36:25 UTC
oo-admin-repair --ssh-keys should be able to deal with such inconsistencies.

Comment 12 david 2014-10-06 18:33:24 UTC
I'm having this same issue, however, I'm not able to delete the domain and recreate since I have other applications. Please advise.

Comment 13 andriykalashnykov@gmail.com 2014-10-06 19:27:14 UTC
i have this issue, tried to delete all applications, that didn't fix it.

Comment 14 Abhishek Gupta 2014-10-09 23:24:49 UTC
Can you guys take a look to see if the issue is resolved? If not, give me your domain names and I'll take a look.

Comment 15 andriykalashnykov@gmail.com 2014-10-10 14:54:52 UTC
Issue has been resolved, works fine now.


Note You need to log in before you can comment on or make changes to this bug.