Bug 1128954 - Convoluted way of opening docs from groups
Summary: Convoluted way of opening docs from groups
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI   
(Show other bugs)
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5
Assignee: Alex Eng
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1131739
TreeView+ depends on / blocked
 
Reported: 2014-08-12 00:00 UTC by Hedda Peters
Modified: 2015-01-26 23:27 UTC (History)
4 users (show)

Fixed In Version: 3.5.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-1931)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 23:27:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hedda Peters 2014-08-12 00:00:13 UTC
Description of problem:
Having to chose your language twice before finally being able to open the selected doc for translation.

How reproducible:
always

Steps to Reproduce:
1. open https://translate.zanata.org/zanata/version-group/view/Satellite6 
2. choose language (de - German)
3. choose project (candlepin)
4. choose language (de - German)
5. choose document (keys.po)

Actual results:
Many steps to open a doc, having to select language twice.

Expected results:
More streamlined and clearer process

Comment 1 Alex Eng 2014-08-12 00:37:23 UTC
To navigate to editor faster
1) open https://translate.zanata.org/zanata/version-group/view/Satellite6/projects (this will bring you to project tab under group page)
2) Select your project, click on the language you wish to translate in right column.

Comment 2 Hedda Peters 2014-08-12 00:39:10 UTC
Thanks Alex.

Maybe that should become the default view then?

Comment 3 Luke Brooker 2014-08-14 01:37:07 UTC
Alex, why do we make people choose their language again? Step 4 in Hedda's list should not exist. We should be sending them directly to the document list with the language selected.

Can we please change this?

Also, I will be working on improving both the group and project pages in the future. Thanks for bringing this up, I will keep it in mind for future changes.

Comment 4 Alex Eng 2014-08-14 02:37:02 UTC
Luke, we didn't schedule this change "sending them directly to the document list with the language selected." on any release.

I will make the change in this sprint.

Comment 5 Alex Eng 2014-08-14 03:42:26 UTC
Pull request:

https://github.com/zanata/zanata-server/pull/555

Comment 6 Ding-Yi Chen 2014-08-20 06:53:30 UTC
VERIFIED with Zanata 3.5.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-1931)

Comment 7 Ding-Yi Chen 2014-09-01 01:16:04 UTC
*** Bug 1131739 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.