Bug 112898 - Bad Yarrow Installation rpmdb fatal region error
Bad Yarrow Installation rpmdb fatal region error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 11:28 EST by Salvador Maravilla Gil
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file of idential failure. (same error on .tar file.) (12.86 KB, application/octet-stream)
2004-03-17 07:52 EST, Steven Gallacher
no flags Details

  None (edit)
Description Salvador Maravilla Gil 2004-01-05 11:28:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
When I try to install Fedora Core 1 - [ Yarrow ] using iso CD
downloaded from Fedora main servers and tested by md5sum, I get a
rpmdb: fatal region error on almost every package that I install and
when I reboot the pc the grub can't locate the vmlinuz file.

I boot with a Knoppix CD and check the /boot directory and saw that
there wasn't vmlinuz or initrd files.

I try to install on ext3 and ext2 filesystem and get the same result.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot with Fedora Core Yarrow
2.Custom installation using DiskDruid
3.Proced to install
4.See tty1 to see error messages
    

Additional info:
Comment 1 Jeremy Katz 2004-01-05 11:48:58 EST
Does booting with 'linux allowcddma' work any better?
Comment 2 Juliano F. Ravasi 2004-01-21 19:28:35 EST
The exactely same problem happened to me. Looking at the intallation
logs, I found out that tar-1.13.25-12.i386.rpm was somehow damaging
the rpm database. I tryed at least 10 times, with different partition
schemes, instalation types, and even a network (NFS) instalation, and
was always at this file that the database got corrupted.

All my CDs were md5sum-checked, tested, and all rpm signatures were
verified. Memtest86 didn't find any problem. I didn't believed that
was a hardware problem, since this computer was being used until today
morning with other linux versions without any problem.

I decided to do a BIOS upgrade, and the problem simply vanished. My
motherboard is an ASUS P4T Socket423 running a P4 at 1.4GHz. The old
BIOS revision 1005 was upgraded to revision 1007.

http://www.redhat.com/archives/fedora-list/2003-November/msg00993.html
states the same problem with a similar motherboard.

Maybe it is a good idea to add a note on release notes of future
releases, explaining that Fedora might fail in some ASUS motherboards
without the lastest BIOS upgrade.

Regards.
Comment 3 Steven Gallacher 2004-03-17 07:52:54 EST
Created attachment 98603 [details]
Log file of idential failure.  (same error on .tar file.)

I have received the same error on every attempt I have made to install FC 1,
both from CD and FTP installs.	Custom and standard seem to fail.  
The end result is that most packages don't install, including the Kernel, which
means the system fails a reboot.
Interestingly, the system is also a P4 1.45 GHz, although I'm sure that's
coincidence...
Comment 4 Jeremy Katz 2004-10-05 11:59:21 EDT
This seems to not be a problem in newer releases of Fedora Core.
Comment 5 Barry K. Nathan 2004-11-29 02:15:32 EST
Bug 141084 claims to be the (re)appearance of this bug in FC2 and FC3,
for what that's worth...

Note You need to log in before you can comment on or make changes to this bug.