Bug 112928 - rhgb chooses dimensions from primary monitor but displays on left most monitor when using dual head
rhgb chooses dimensions from primary monitor but displays on left most monito...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
: 126277 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 20:06 EST by Aaron VanDevender
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 05:13:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhgb-dual-head.patch (4.17 KB, patch)
2004-07-12 00:01 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Aaron VanDevender 2004-01-05 20:06:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I have two minotors going. The primary runs at 1600x1200, and the
secondary runs at 1024x768. The secondary is to the left of the
primary. When RHGB runs, it creates a grey field that is 1600x1200 and
displays it with its leftmost edge aligned with the left edge of the
left (secondary) monitor. This monitor is, of course, insufficiently
large to accomitate the 1600x1200 rectangle, and so the remainder of
the rectangle shows up on the right (primary) monitor. The balence of
the primary monitor is black. The status slider dialog shows up
centered on the grey field, which happens to land it about 2/3 to the
right on the secondary monitor.

Version-Release number of selected component (if applicable):
rhgb-0.11.2-1

How reproducible:
Always

Steps to Reproduce:
1. Plug in two monitors and put monitor 0 on the rightof monitor 1
2. boot using rhgb
    

Expected Results:  The correct thing to do would be to grey rectangle
which spans both of the monitors, and then open up the status slider
dialog centered on the primary monitor.
Comment 1 Bastien Nocera 2004-07-11 23:00:02 EDT
I can confirm and reproduce this bug.
Comment 2 Bastien Nocera 2004-07-12 00:01:58 EDT
Created attachment 101801 [details]
rhgb-dual-head.patch

Instead of making the splash window a Desktop window (which requires quite a
lot of code to handle properly with displays of different sizes, etc.), make
the window keep on top, and move it to the right display if required.

This patch also fixes bug #115209 which I encountered, and fixes a compile
warning.
Comment 3 Bastien Nocera 2004-07-12 00:05:43 EDT
*** Bug 126277 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Veillard 2004-07-12 05:13:16 EDT
Applied patch and released rhgb-0.12-1 , this should hit rawhide 
as soon as an export of the build system is done,

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.