Bug 1129300 - [RFE] support degraded mdadm-based RAID creation in the GUI installer
Summary: [RFE] support degraded mdadm-based RAID creation in the GUI installer
Keywords:
Status: CLOSED DUPLICATE of bug 61844
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 14:42 UTC by Jiri Jaburek
Modified: 2014-08-13 14:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 14:38:46 UTC


Attachments (Terms of Use)
screenshot of anaconda GUI installer showing no RAID options (95.03 KB, image/png)
2014-08-12 14:42 UTC, Jiri Jaburek
no flags Details
screenshot of anaconda GUI installer showing RAID options (139.90 KB, image/jpeg)
2014-08-12 14:49 UTC, David Shea
no flags Details

Description Jiri Jaburek 2014-08-12 14:42:34 UTC
Created attachment 926082 [details]
screenshot of anaconda GUI installer showing no RAID options

Description of problem:

The GUI installer doesn't seem to support non-btrfs software raid, the initial "partitioning scheme" selection doesn't include it and it's not available in any mountpoint options after mountpoint creation, see the attached image.


Version-Release number of selected component (if applicable):
(the version used for the official RHEL-7.0 DVD)

Actual results:
no softward raid configuration possible using the GUI installer

Expected results:
being able to configure software raid (mdadm) over any block devices (entire disks, standard partitions, LVM LVs, existing software raids)

Additional info:
Software raid works just fine using a custom kickstart, it's just the GUI installer, which lacks the capability. My use case was to create two degraded raids (v0.90 metadata for /boot, v1.2 metadata for /) on a single drive, adding a second drive later.

Comment 2 David Shea 2014-08-12 14:49:18 UTC
Created attachment 926084 [details]
screenshot of anaconda GUI installer showing RAID options

We already do? Did you choose more than one disk to install to?

Comment 3 Jiri Jaburek 2014-08-12 14:53:02 UTC
(In reply to David Shea from comment #2)
> Created attachment 926084 [details]
> screenshot of anaconda GUI installer showing RAID options
> 
> We already do? Did you choose more than one disk to install to?

No, as I said:

(In reply to Jiri Jaburek from comment #0)
> My use case was to create two
> degraded raids (v0.90 metadata for /boot, v1.2 metadata for /) on a single
> drive, adding a second drive later.

If the installer doesn't support this, please append "for degraded RAIDs" to the bug summary.

Thanks,
Jiri

Comment 4 David Shea 2014-08-12 15:06:23 UTC
Anaconda does not support degraded RAID.

Comment 5 Chris Lumens 2014-08-13 14:38:46 UTC

*** This bug has been marked as a duplicate of bug 61844 ***


Note You need to log in before you can comment on or make changes to this bug.