Bug 1129307 - rhel-7-server-rh-common-beta-rpms ships m2crypto package that conflicts with version in 7Server repo
Summary: rhel-7-server-rh-common-beta-rpms ships m2crypto package that conflicts with ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Jason Montleon
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1131260
Blocks: 950743
TreeView+ depends on / blocked
 
Reported: 2014-08-12 14:51 UTC by Stephen Benjamin
Modified: 2014-09-11 12:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:18:43 UTC


Attachments (Terms of Use)

Description Stephen Benjamin 2014-08-12 14:51:41 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a RHEL 7 using 'Satellite Kickstart Default' using an activation key that enables rhel-7-server-rh-common-beta-rpms 
2. Attempt to run "yum update"

Actual results:
     
    ========================================================================================================================================================================
     Package                                   Arch                Version
    Repository                                      Size
    ========================================================================================================================================================================
    Installing:
     kernel                                    x86_64
    3.10.0-123.6.3.el7                                  rhel-7-server-rpms
    29 M
    Updating:
     NetworkManager                            x86_64
    1:0.9.9.1-25.git20140326.4dba720.el7_0              rhel-7-server-rpms
    1.4 M
     NetworkManager-config-server              x86_64
    1:0.9.9.1-25.git20140326.4dba720.el7_0              rhel-7-server-rpms
    103 k
     NetworkManager-glib                       x86_64
    1:0.9.9.1-25.git20140326.4dba720.el7_0              rhel-7-server-rpms
    369 k
     NetworkManager-tui                        x86_64
    1:0.9.9.1-25.git20140326.4dba720.el7_0              rhel-7-server-rpms
    191 k
     gnutls                                    x86_64
    3.1.18-9.el7_0                                      rhel-7-server-rpms
    609 k
     json-c                                    x86_64              0.11-4.el7_0
    rhel-7-server-rpms                              31 k
     kernel-tools                              x86_64
    3.10.0-123.6.3.el7                                  rhel-7-server-rpms
    672 k
     kernel-tools-libs                         x86_64
    3.10.0-123.6.3.el7                                  rhel-7-server-rpms
    612 k
     kexec-tools                               x86_64
    2.0.4-32.el7_0.2                                    rhel-7-server-rpms
    321 k
     libdb                                     x86_64
    5.3.21-17.el7_0.1                                   rhel-7-server-rpms
    718 k
     libdb-utils                               x86_64
    5.3.21-17.el7_0.1                                   rhel-7-server-rpms
    101 k
     libgudev1                                 x86_64
    208-11.el7_0.2                                      rhel-7-server-rpms
    48 k
     libtasn1                                  x86_64              3.3-5.el7_0
    rhel-7-server-rpms                             316 k
     lzo                                       x86_64
    2.06-6.el7_0.2                                      rhel-7-server-rpms
    59 k
     m2crypto                                  x86_64
    0.21.1.pulp-13.el7sat
    rhel-7-server-rh-common-beta-rpms              489 k
     mariadb-libs                              x86_64
    1:5.5.37-1.el7_0                                    rhel-7-server-rpms
    753 k
     microcode_ctl                             x86_64
    2:2.1-7.1.el7_0.2                                   rhel-7-server-rpms
    490 k
     nspr                                      x86_64
    4.10.6-1.el7_0                                      rhel-7-server-rpms
    125 k
     nss                                       x86_64
    3.15.4-7.el7_0                                      rhel-7-server-rpms
    877 k
     nss-sysinit                               x86_64
    3.15.4-7.el7_0                                      rhel-7-server-rpms
    48 k
     nss-tools                                 x86_64
    3.15.4-7.el7_0                                      rhel-7-server-rpms
    469 k
     openssl                                   x86_64
    1:1.0.1e-34.el7_0.3                                 rhel-7-server-rpms
    705 k
     openssl-libs                              x86_64
    1:1.0.1e-34.el7_0.3                                 rhel-7-server-rpms
    939 k
     selinux-policy                            noarch
    3.12.1-153.el7_0.10                                 rhel-7-server-rpms
    340 k
     selinux-policy-targeted                   noarch
    3.12.1-153.el7_0.10                                 rhel-7-server-rpms
    3.8 M
     subscription-manager                      x86_64
    1.10.14-9.el7_0                                     rhel-7-server-rpms
    711 k
     systemd                                   x86_64
    208-11.el7_0.2                                      rhel-7-server-rpms
    2.6 M
     systemd-libs                              x86_64
    208-11.el7_0.2                                      rhel-7-server-rpms
    153 k
     systemd-sysv                              x86_64
    208-11.el7_0.2                                      rhel-7-server-rpms
    35 k
     tuned                                     noarch
    2.3.0-11.el7_0.3                                    rhel-7-server-rpms
    145 k
     tzdata                                    noarch              2014e-1.el7
    rhel-7-server-rpms                             433 k
     
    Transaction Summary
    ========================================================================================================================================================================
    Install   1 Package
    Upgrade  31 Packages
     
    Total size: 47 M
    Is this ok [y/d/N]: y
    Downloading packages:
    Running transaction check
    Running transaction test
     
     
    Transaction check error:
      file /usr/lib64/python2.7/site-packages/M2Crypto-0.21.1-py2.7.egg-info
    from install of m2crypto-0.21.1.pulp-13.el7sat.x86_64 conflicts with file
    from package m2crypto-0.21.1-15.el7.x86_64
     
    Error Summary
    -------------



Expected results:
yum update succeeds


Additional info:

Comment 2 Jeff Ortel 2014-08-20 18:44:52 UTC
To resolve this - it would be helpful to know which package requires: m2crypto-0.21.1-15 and is causing it to be installed.  Can you provide this?

Comment 3 Jason Montleon 2014-08-20 18:49:35 UTC
Nothing requires the specific version, however we've had a patched m2crypto since before I've been building packages for Satellite. These are the packages on a Sat 6 system that require m2crypto:

[root@el7-smoketest ~]# rpm -q --whatrequires m2crypto | sort -u
pulp-server-2.4.0-0.30.beta.el7sat.noarch
python-pulp-bindings-2.4.0-0.30.beta.el7sat.noarch
python-rhsm-1.10.12-2.el7.x86_64
redhat-support-lib-python-0.9.6-0.el7.noarch
yum-rhn-plugin-2.0.1-4.el7.noarch

Comment 4 Miloslav Trmač 2014-08-20 19:26:39 UTC
(In reply to Jeff Ortel from comment #2)
> To resolve this - it would be helpful to know which package requires:
> m2crypto-0.21.1-15 and is causing it to be installed.  Can you provide this?

FWIW there is no exact version dependency: the two m2crypto package differ in *.egg-info being a file vs. a directory, and rpm can’t upgrade from one to the other.

Comment 5 Jason Montleon 2014-08-25 19:48:27 UTC
The difference was due to python-setuptools not being a dependency on our version. Adding the dependency seems to make this a dir with files matching the RHEL 7.0 version and it updates cleanly now.

Comment 10 Corey Welton 2014-09-05 01:10:24 UTC
Verified in Satellite-6.0.4-RHEL-7-20140904.1, Satellite-6.0.4-RHEL-6-20140904.1 that our dependency exists on the RHEL version of the package.

Comment 11 Bryan Kearney 2014-09-11 12:18:43 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.