Bug 1129386 - Augeas cannot parse /etc/rsyslog.conf with TCP hosts
Summary: Augeas cannot parse /etc/rsyslog.conf with TCP hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: augeas
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1129508
TreeView+ depends on / blocked
 
Reported: 2014-08-12 15:42 UTC by Ryan Barry
Modified: 2015-03-05 09:25 UTC (History)
1 user (show)

Fixed In Version: augeas-1.1.0-13.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1129508 (view as bug list)
Environment:
Last Closed: 2015-03-05 09:25:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0399 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-03-05 14:17:57 UTC

Description Ryan Barry 2014-08-12 15:42:16 UTC
Description of problem:
Augeas cannot parse

Version-Release number of selected component (if applicable):
augeas-1.1.0-12.el7

How reproducible:
Always

Steps to Reproduce:
1. Enter a TCP hostname in rsyslog.conf (ex: @@10.0.0.1:514)
2. Attempt to do anything with augeas

Actual results:
/augeas/files/etc/rsyslog.conf/error = "parse_failed" /augeas/files/etc/rsyslog.conf/error/pos = "2815" /augeas/files/etc/rsyslog.conf/error/line = "79" /augeas/files/etc/rsyslog.conf/error/char = "0" /augeas/files/etc/rsyslog.conf/error/lens = "/usr/share/augeas/lenses/dist/rsyslog.aug:30.10-.57:" /augeas/files/etc/rsyslog.conf/error/message = "Get did not match entire input" 

Expected results:
augeas works

Additional info:
This is fixed upstream and in Fedora. Can we get it into RHEL?

https://fedorahosted.org/augeas/ticket/364#comment:1

Comment 2 Lingfei Kong 2014-08-13 01:53:16 UTC
Can reproduce with augeas-1.1.0-12.el7

Comment 4 Lingfei Kong 2014-09-16 08:09:54 UTC
Can verify with augeas-1.1.0-13.el7

Steps to verify:
#cat /etc/rsyslog.conf
*.* @@10.x.x.x:5444

#augtool print /files/etc/rsyslog.conf
/files/etc/rsyslog.conf
/files/etc/rsyslog.conf/entry
/files/etc/rsyslog.conf/entry/selector
/files/etc/rsyslog.conf/entry/selector/facility = "*"
/files/etc/rsyslog.conf/entry/selector/level = "*"
/files/etc/rsyslog.conf/entry/action
/files/etc/rsyslog.conf/entry/action/protocol = "@@"
/files/etc/rsyslog.conf/entry/action/hostname = "10.x.x.x"
/files/etc/rsyslog.conf/entry/action/port = "5444"

Comment 6 errata-xmlrpc 2015-03-05 09:25:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0399.html


Note You need to log in before you can comment on or make changes to this bug.