Bug 1129508 - Augeas cannot parse /etc/rsyslog.conf with TCP hosts
Summary: Augeas cannot parse /etc/rsyslog.conf with TCP hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: augeas
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1129386
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 02:14 UTC by Lingfei Kong
Modified: 2015-07-22 05:40 UTC (History)
7 users (show)

Fixed In Version: augeas-1.0.0-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1129386
Environment:
Last Closed: 2015-07-22 05:40:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1256 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-07-20 17:50:00 UTC

Comment 1 Lingfei Kong 2014-08-13 02:15:42 UTC
Can reproduce with augeas-1.0.0-7.el6

Comment 3 Bryan Kearney 2014-11-03 19:48:16 UTC
Moving bugs to 6.7

Comment 4 Bryan Kearney 2014-11-03 19:49:15 UTC
Moving bugs to 6.7

Comment 5 Bryan Kearney 2014-11-03 19:54:02 UTC
Moving bugs to 6.7

Comment 8 Hu Zhang 2015-03-03 09:04:57 UTC
Reproduced with augeas-1.0.0-7.el6.x86_64.

Verified with the package:
augeas-1.0.0-8.el6.x86_64

Steps to verify:
1. Add the following line to /etc/rsyslog.conf

*.* @@10.x.x.x:5444

2. # augtool print /augeas/files/etc/rsyslog.conf/error
Nothing returned.
   # augtool print /files/etc/rsyslog.conf
...
/files/etc/rsyslog.conf/entry[8]
/files/etc/rsyslog.conf/entry[8]/selector
/files/etc/rsyslog.conf/entry[8]/selector/facility = "*"
/files/etc/rsyslog.conf/entry[8]/selector/level = "*"
/files/etc/rsyslog.conf/entry[8]/action
/files/etc/rsyslog.conf/entry[8]/action/protocol = "@@"
/files/etc/rsyslog.conf/entry[8]/action/hostname = "10.x.x.x"
/files/etc/rsyslog.conf/entry[8]/action/port = "5444"

No parse error returned.
So verified.

Comment 11 errata-xmlrpc 2015-07-22 05:40:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1256.html


Note You need to log in before you can comment on or make changes to this bug.