Bug 1129398 - Missing parameter validation when adding new storage domain with advanced options
Summary: Missing parameter validation when adding new storage domain with advanced opt...
Keywords:
Status: CLOSED DUPLICATE of bug 1116616
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.1
Assignee: Tal Nisan
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks: 1193195
TreeView+ depends on / blocked
 
Reported: 2014-08-12 16:42 UTC by Gal Amado
Modified: 2016-02-10 18:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-08 03:51:38 UTC
oVirt Team: Storage


Attachments (Terms of Use)
engine log file (2.97 MB, text/x-log)
2014-08-12 16:42 UTC, Gal Amado
no flags Details
vdsm log file (7.59 MB, text/x-log)
2014-08-12 16:46 UTC, Gal Amado
no flags Details

Description Gal Amado 2014-08-12 16:42:13 UTC
Created attachment 926159 [details]
engine log file

Description of problem:
When adding a new storage domain , for example of Data/NFS type , the advanced params are not validated .

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.5.0-0.0.master.20140804172041.git23b558e.el6

How reproducible:
Happans all the time 

Steps to Reproduce:
1.I've used up and running setup with 2 hosts and 2 iSCSI SD's , and 1 VM 
2.through GUI, Storage tab I've added "New Domain"  
3.Default Domain Function / Storage Type - Data/NFS
4.Fill in valid name and Export Path
5.Expand Advanced parameter
6.Check "Override Default Options"
7.Add an illegal value for example in the "Retransmissions (#)" field put "SOME_STRING"

Actual results:
8.The operation was passed though the illegal value.
9.running mount command on the host showes that the mount was created with retrans=6    

Expected results:
8.The GUI should validate illegal value and fail the operation.
9.The mount shouldn't be created.    


Additional info:

I've used netapp.qa.lab.tlv.redhat.com:/vol/vol_gamado_nfs01 for tha

Comment 1 Gal Amado 2014-08-12 16:46:11 UTC
Created attachment 926160 [details]
vdsm log file

Comment 2 Gal Amado 2014-08-12 16:48:00 UTC
In REST API , the transaction failed for "Illegal request format".

Comment 3 Allon Mureinik 2014-08-13 11:32:29 UTC
Isn't this a duplicate of bug 1116616 ?
If not - could you please highlight the differences?

Comment 4 Gal Amado 2014-09-08 03:51:38 UTC
Correct ,
This is a duplication of bug 1116616 .
Can I just close it ?

*** This bug has been marked as a duplicate of bug 1116616 ***


Note You need to log in before you can comment on or make changes to this bug.