Bug 1129521 - Not used NICs should be detected and should not be set to BOOTPROTO=dhcp and ONBOOT=yes
Summary: Not used NICs should be detected and should not be set to BOOTPROTO=dhcp and...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1157823 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 04:52 UTC by Ofer Blaut
Modified: 2014-11-04 17:01 UTC (History)
7 users (show)

Fixed In Version: rhel-osp-installer-0.4.7-1.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: All NICs on a machine were configured to be up after a host is provisioned. Consequence: Nics not configured and not needed would be enabled Fix: Only nics configured in RHEL-OSP Installer are enabled. Result:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:01:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Ofer Blaut 2014-08-13 04:52:29 UTC
Description of problem:

My setup has OOB NICs that are used for IPMI
which also apears in OS

rhel-osp-installer should detected these interfaces and should not set them to BOOTPROTO=dhcp and ONBOOT=yes , result with additional ip address and route 

This follows bug https://bugzilla.redhat.com/show_bug.cgi?id=1118381

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Dan Radez 2014-08-13 12:57:41 UTC
Could you elaborate on how these are detected or provide hardware for this to be debugged on?

Comment 4 Ofer Blaut 2014-08-13 19:31:06 UTC
Don't know how to detect them bug this was suggest in bug https://bugzilla.redhat.com/show_bug.cgi?id=1118381


Any host support IPMI can be used to reproduce the issue

Comment 5 Mike Burns 2014-10-07 16:17:21 UTC
If you can reproduce this, please reopen and let us know and provide access to the machine

Comment 6 Ofer Blaut 2014-10-29 07:27:48 UTC
Issue reproduced again

[root@mac441ea1733d43 ~]# ifconfig | more
br-int: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::38af:7bff:fe2a:6e45  prefixlen 64  scopeid 0x20<link>
        ether 3a:af:7b:2a:6e:45  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 648 (648.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

br-tun: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::68ce:19ff:feab:6741  prefixlen 64  scopeid 0x20<link>
        ether 6a:ce:19:ab:67:41  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 648 (648.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0f0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.35.160.19  netmask 255.255.255.0  broadcast 10.35.160.255
        inet6 fe80::82c1:6eff:fe07:d248  prefixlen 64  scopeid 0x20<link>
        ether 80:c1:6e:07:d2:48  txqueuelen 1000  (Ethernet)
        RX packets 211291  bytes 14008287 (13.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 868  bytes 201403 (196.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0f1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::82c1:6eff:fe07:d24c  prefixlen 64  scopeid 0x20<link>
        ether 80:c1:6e:07:d2:4c  txqueuelen 1000  (Ethernet)
        RX packets 939191  bytes 231904553 (221.1 MiB)
        RX errors 0  dropped 1456  overruns 0  frame 0
        TX packets 33353  bytes 2673616 (2.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0f1.189: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.35.174.21  netmask 255.255.255.0  broadcast 10.35.174.255
        inet6 fe80::82c1:6eff:fe07:d24c  prefixlen 64  scopeid 0x20<link>
        ether 80:c1:6e:07:d2:4c  txqueuelen 0  (Ethernet)
        RX packets 121243  bytes 177167133 (168.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 33308  bytes 2664126 (2.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0f1.195: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::82c1:6eff:fe07:d24c  prefixlen 64  scopeid 0x20<link>
        ether 80:c1:6e:07:d2:4c  txqueuelen 0  (Ethernet)
        RX packets 23122  bytes 1176440 (1.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 26  bytes 4020 (3.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp5s0f0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.35.160.220  netmask 255.255.255.0  broadcast 10.35.160.255
        inet6 fe80::461e:a1ff:fe73:3d42  prefixlen 64  scopeid 0x20<link>
        ether 44:1e:a1:73:3d:42  txqueuelen 1000  (Ethernet)
        RX packets 428168  bytes 34999221 (33.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 690  bytes 144160 (140.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfbe60000-fbe80000  

enp5s0f1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.2  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::461e:a1ff:fe73:3d43  prefixlen 64  scopeid 0x20<link>
        ether 44:1e:a1:73:3d:43  txqueuelen 1000  (Ethernet)
        RX packets 8443386  bytes 1370160664 (1.2 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8260937  bytes 1315265412 (1.2 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfbee0000-fbf00000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 5761800  bytes 909121673 (867.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5761800  bytes 909121673 (867.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[root@mac441ea1733d43 ~]# grep enp4s0f0 /var/log/messages 
Oct 28 21:30:21 mac441ea1733d43 systemd-udevd[596]: renamed network interface eth0 to enp4s0f0
Oct 28 21:30:24 mac441ea1733d43 network: Bringing up interface enp4s0f0:
Oct 28 21:30:24 mac441ea1733d43 dhclient[1147]: DHCPDISCOVER on enp4s0f0 to 255.255.255.255 port 67 interval 4 (xid=0x69bc262c)
Oct 28 21:30:24 mac441ea1733d43 dhclient[1147]: DHCPREQUEST on enp4s0f0 to 255.255.255.255 port 67 (xid=0x69bc262c)
Oct 28 21:30:27 mac441ea1733d43 network: Determining IP information for enp4s0f0... done.
Oct 28 21:31:50 mac441ea1733d43 kernel: 8021q: adding VLAN 0 to HW filter on device enp4s0f0
Oct 29 02:27:26 mac441ea1733d43 dhclient[1248]: DHCPREQUEST on enp4s0f0 to 10.35.28.1 port 67 (xid=0x69bc262c)
Oct 29 02:27:26 mac441ea1733d43 dhclient[1248]: DHCPDECLINE on enp4s0f0 to 255.255.255.255 port 67 (xid=0x69bc262c)


interface enp5s0f0 is connected to the same switch as enp4s0f0 ( which is used for tenant network ) , but i don't use it and it should stay down/not configured

Comment 7 Ofer Blaut 2014-10-29 07:31:57 UTC
 more logs 
[root@mac441ea1733d43 ~]# cat /etc/sysconfig/network-scripts/ifcfg-enp4s0f0
BOOTPROTO="dhcp"
DEVICE="enp4s0f0"
HWADDR="80:c1:6e:07:d2:48"
ONBOOT=yes
PEERROUTES=no
NM_CONTROLLED=no
PEERDNS=no
DEFROUTE=no
[root@mac441ea1733d43 ~]# cat /etc/sysconfig/network-scripts/ifcfg-enp5s0f0
HWADDR=44:1E:A1:73:3D:42
TYPE=Ethernet
BOOTPROTO=dhcp
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=enp5s0f0
UUID=c23ba287-aea2-4cbd-b451-d872ae738ca4
ONBOOT=yes
PEERDNS=no
DEFROUTE=no
[root@mac441ea1733d43 ~]# grep enp5s0f0 /var/log/messages 
Oct 28 21:30:20 mac441ea1733d43 systemd-udevd[600]: renamed network interface eth2 to enp5s0f0
Oct 28 21:31:28 mac441ea1733d43 network: Bringing up interface enp5s0f0:
Oct 28 21:31:28 mac441ea1733d43 kernel: IPv6: ADDRCONF(NETDEV_UP): enp5s0f0: link is not ready
Oct 28 21:31:31 mac441ea1733d43 kernel: igb: enp5s0f0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
Oct 28 21:31:31 mac441ea1733d43 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): enp5s0f0: link becomes ready
Oct 28 21:31:31 mac441ea1733d43 dhclient[1409]: DHCPDISCOVER on enp5s0f0 to 255.255.255.255 port 67 interval 6 (xid=0x6ea28e20)
Oct 28 21:31:37 mac441ea1733d43 dhclient[1409]: DHCPDISCOVER on enp5s0f0 to 255.255.255.255 port 67 interval 6 (xid=0x6ea28e20)
Oct 28 21:31:38 mac441ea1733d43 dhclient[1409]: DHCPREQUEST on enp5s0f0 to 255.255.255.255 port 67 (xid=0x6ea28e20)
Oct 28 21:31:40 mac441ea1733d43 network: Determining IP information for enp5s0f0... done.
Oct 28 21:31:50 mac441ea1733d43 kernel: 8021q: adding VLAN 0 to HW filter on device enp5s0f0
Oct 29 02:44:28 mac441ea1733d43 dhclient[1468]: DHCPREQUEST on enp5s0f0 to 10.35.28.1 port 67 (xid=0x6ea28e20)
Oct 29 02:44:31 mac441ea1733d43 dhclient[1468]: DHCPREQUEST on enp5s0f0 to 10.35.28.1 port 67 (xid=0x6ea28e20)
Oct 29 02:44:37 mac441ea1733d43 dhclient[1468]: DHCPREQUEST on enp5s0f0 to 10.35.28.1 port 67 (xid=0x6ea28e20)
Oct 29 02:44:52 mac441ea1733d43 dhclient[1468]: DHCPREQUEST on enp5s0f0 to 10.35.28.1 port 67 (xid=0x6ea28e20)
Oct 29 02:45:06 mac441ea1733d43 dhclient[1468]: DHCPREQUEST on enp5s0f0 to 10.35.28.1 port 67 (xid=0x6ea28e20)
Oct 29 02:45:16 mac441ea1733d43 dhclient[1468]: DHCPREQUEST on enp5s0f0 to 10.35.28.1 port 67 (xid=0x6ea28e20)

Comment 8 Ofer Blaut 2014-10-29 07:36:16 UTC
(In reply to Ofer Blaut from comment #0)
> Description of problem:
> 
> My setup has OOB NICs that are used for IPMI
> which also apears in OS
> 
> rhel-osp-installer should detected these interfaces and should not set them
> to BOOTPROTO=dhcp and ONBOOT=yes , result with additional ip address and
> route 
> 
> This follows bug https://bugzilla.redhat.com/show_bug.cgi?id=1118381

Workaround :

add to kickstart 
sed -i 's/ONBOOT=yes/ONBOOT=no/'  /etc/sysconfig/network-scripts/ifcfg-enp5s0f0
ifconfig enp5s0f0 down

where enp5s0f0 is the interface you want to shut down
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Comment 9 Ofer Blaut 2014-10-29 07:41:17 UTC
(In reply to Ofer Blaut from comment #0)
> Description of problem:
> 
> My setup has OOB NICs that are used for IPMI
> which also apears in OS
Interace not used by staypuft subsets should not be set to DHCP, when deploying .
> 
> rhel-osp-installer should detected these interfaces and should not set them
> to BOOTPROTO=dhcp and ONBOOT=yes , result with additional ip address and
> route 
> 
> This follows bug https://bugzilla.redhat.com/show_bug.cgi?id=1118381
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Comment 10 Mike Burns 2014-10-29 11:53:30 UTC
this is covered in another open bug already

*** This bug has been marked as a duplicate of bug 1157823 ***

Comment 11 Mike Burns 2014-10-29 14:23:52 UTC
reversing the duplicate

Comment 12 Mike Burns 2014-10-29 14:24:08 UTC
*** Bug 1157823 has been marked as a duplicate of this bug. ***

Comment 13 Brad P. Crochet 2014-10-30 12:51:51 UTC
PR Available: https://github.com/theforeman/foreman-installer-staypuft/pull/109

Comment 16 Alexander Chuzhoy 2014-10-31 16:26:24 UTC
Verified:
rhel-osp-installer-0.4.7-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.13-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.32-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch


The non-used in deployment interface isn't UP. Checking its configuration file:

BOOTPROTO="none"
ONBOOT=no

Comment 18 errata-xmlrpc 2014-11-04 17:01:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.