Bug 1129661 - df does not respect device path if specified
Summary: df does not respect device path if specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: coreutils
Version: 7.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On: 812449
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 12:39 UTC by Tomas Dolezal
Modified: 2015-11-19 12:44 UTC (History)
5 users (show)

Fixed In Version: coreutils-8.22-13.el7
Doc Type: Bug Fix
Doc Text:
TBD - sorry still not sure what to enter here (it is about df differences between RHEL 6 and RHEL 7 caused by /etc/mtab being now symlink to /proc/mounts. Cause: Consequence: Fix: Result:
Clone Of: 812449
Environment:
Last Closed: 2015-11-19 12:44:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2160 normal SHIPPED_LIVE coreutils bug fix and enhancement update 2015-11-19 11:10:56 UTC

Comment 3 Ondrej Vasik 2015-05-13 18:46:31 UTC
I believe this is not a bug, but I had no time to further investigate this so far. Definitely not a regression - code from the original fix is included in RHEL 7 coreutils - but further extended by upstream.
RHEL 7 df uses extended logic to determine which mountpoint should be shown (from multiple possible options). As Ondrej worked on the deduplication, setting needinfo on him, but I tend to not a bug this request (we have multiple bug reports about deduplication improvements).

Comment 4 Ondrej Oprala 2015-05-14 12:18:36 UTC
As per conversation with Ondrej, we found out the patch we applied to rhel-6 is missing in 7. We further discussed, that it might be better to patch rhel7
with the upstream version of get_disk(), with the last change in the
dbd7c9452 upstream commit.

Comment 10 errata-xmlrpc 2015-11-19 12:44:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2160.html


Note You need to log in before you can comment on or make changes to this bug.