Bug 812449 - df: dereference symlinks when command line arguments
df: dereference symlinks when command line arguments
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coreutils (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
Tomas Dolezal
:
Depends On:
Blocks: 1129661
  Show dependency treegraph
 
Reported: 2012-04-13 14:47 EDT by Ondrej Vasik
Modified: 2014-10-14 02:34 EDT (History)
4 users (show)

See Also:
Fixed In Version: coreutils-8.4-37.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1129661 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:34:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1457 normal SHIPPED_LIVE coreutils bug fix and enhancement update 2014-10-13 21:10:58 EDT

  None (edit)
Description Ondrej Vasik 2012-04-13 14:47:36 EDT
Description of problem:
"df" command does not display target device information when
a symbolic link is specified as a parameter.

Steps to Reproduce:
1. Execute "df" command with a symbolic link as a parameter
   for indicating device.

   ex.
   # df /dev/disk/by-uuid/322f18fe-6d3e-4d9f-84a7-42be969d36f4
  
Actual results:
Information about the file system on which file resides is shown.

Expected results:
With --dereference option, symlink is dereferenced and information for the device is shown.
Comment 2 Ondrej Oprala 2013-12-04 08:30:51 EST
This issue is now resolved upstream: http://git.savannah.gnu.org/gitweb/?p=coreutils.git;a=commit;h=33660b4973baf66423207615bef0d277ca7a5938 .
Comment 3 Ondrej Vasik 2013-12-04 13:52:15 EST
Should be assigned until pushed to distgit...
Comment 8 errata-xmlrpc 2014-10-14 02:34:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1457.html

Note You need to log in before you can comment on or make changes to this bug.