Bug 1129794 - Provide a method to upgrade reports from more than just the previous version
Summary: Provide a method to upgrade reports from more than just the previous version
Keywords:
Status: CLOSED DUPLICATE of bug 1123751
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.4.1-1
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 3.4.1
Assignee: Shirly Radco
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 17:00 UTC by James W. Mills
Modified: 2019-04-28 09:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 09:18:45 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description James W. Mills 2014-08-13 17:00:04 UTC
Description of problem:

Many customers are doing "double upgrades" from 3.2 to 3.4.  In this process, they are not noticing/following the instructions when upgrading from 3.2/3.3 that upgrade the rhevm-reports configuration.

When they move to 3.4 and they are forced to take rhevm-reports into consideration, the engine-setup process fails because it cannot understand how to access the rhevmreports database.


Version-Release number of selected component (if applicable):

rhevm-reports-3.2.x
rhevm-reports-3.3.x
rhevm-reports-3.4.x

How reproducible:

100%

Steps to Reproduce:
1. Upgrade rhevm and rhevm-reports to 3.3
2. Do *not* run rhevm-reports-setup
3. Upgrade rhevm and rhevm-reports to 3.4
4. Run engine-setup

Actual results:

engine-setup fails because it cannot access the reports database

Expected results:

The upgrade process can move from a 3.2 configuration to a 3.4 configuration.

Additional info:

Fixing this situation is quite painful.  Multiple downgrades of rhevm-reports/jasper are required.  Taken in conjunction with dwhd, it is a very involved process.

Comment 2 Yedidyah Bar David 2014-08-14 09:18:45 UTC
Please see https://bugzilla.redhat.com/show_bug.cgi?id=1111749#c19 for a workaround.

The fix in bug #1123751 which will be included in 3.4.2 will make engine-setup refuse to upgrade the engine to 3.4 if dwh/reports 3.2 are found. Users that already upgraded the engine to 3.4.{0,1} will have to use the above workaround. If they still have engine 3.3 they'll simply have to upgrade dwh and reports to 3.3 too before upgrading the engine to 3.4.

*** This bug has been marked as a duplicate of bug 1123751 ***


Note You need to log in before you can comment on or make changes to this bug.