Bug 1123751 - DWH/Reports upgrade from 3.2 to 3.4 fails
Summary: DWH/Reports upgrade from 3.2 to 3.4 fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.4.2
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
: 1129794 1129797 (view as bug list)
Depends On: 1111749
Blocks: 1123858
TreeView+ depends on / blocked
 
Reported: 2014-07-28 07:58 UTC by rhev-integ
Modified: 2019-04-28 10:09 UTC (History)
20 users (show)

Fixed In Version: av11 - rhevm-dwh-3.4.2-1.el6ev
Doc Type: Bug Fix
Doc Text:
A direct upgrade of Data Warehouse and/or Reports from 3.2 to 3.4 was not expected, not supported in the code, and not tested, but also not prevented. Such an upgrade can happen if, for example, a system has the 3.2 "engine", "dwh", and "reports" packages installed and set up; then "engine" is upgraded to 3.3; the "dwh" and "reports" packages are upgraded to 3.3 but not set up; and then an attempt to upgrade all packages to 3.4 is made. An attempt to do such an upgrade fails and rolls back with an unclear error message. To fix this, the 3.4 "rhevm-setup-plugins" package was modified to check early in the process if 3.2 "dwh" and "reports" are set up. Now if 3.2 "dwh" or "reports" are set up on the system, engine-setup aborts early (so that a rollback is not required) with a useful error message.
Clone Of: 1111749
Environment:
Last Closed: 2014-09-04 12:47:41 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1154 normal SHIPPED_LIVE rhevm-dwh 3.4.2 bug fix update 2014-09-04 16:47:10 UTC
Red Hat Knowledge Base (Solution) 1144503 None None None Never

Comment 1 Yedidyah Bar David 2014-07-31 10:27:19 UTC
Note to QE:

Steps to reproduce:
1. install/setup engine/dwh/reports 3.2
2. yum update rhevm-setup rhevm-dwh rhevm-reports to 3.3
3. upgrade engine to 3.3
4. yum install rhevm-setup 3.4
5. engine-setup
6. yum install rhevm-dwh-setup and/or rhevm-reports-setup 3.4
7. engine-setup fails

To verify:
Repeat above with a fixed version. Step 5 "engine-setup" will fail with a message explaining how to continue.

You could have also skipped step 5 and try to have a single 'engine-setup' upgrade all of them at once. The fixed version will abort with the same message, which is phrased generally - for this flow it will imply you'll have to also downgrade rhevm-dwh/rhevm-reports to 3.3.

Comment 3 Yedidyah Bar David 2014-08-14 09:18:45 UTC
*** Bug 1129794 has been marked as a duplicate of this bug. ***

Comment 4 Shirly Radco 2014-08-14 10:13:26 UTC
*** Bug 1129797 has been marked as a duplicate of this bug. ***

Comment 5 Yedidyah Bar David 2014-08-24 14:22:31 UTC
*** Bug 1132394 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2014-09-04 12:47:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1154.html


Note You need to log in before you can comment on or make changes to this bug.