Bug 1129804 - Missing dependancy in virt-manager. It requires libvirt-daemon-config-network
Summary: Missing dependancy in virt-manager. It requires libvirt-daemon-config-network
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 20
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 17:17 UTC by Kurt Seifried
Modified: 2014-08-15 15:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 15:22:35 UTC


Attachments (Terms of Use)

Description Kurt Seifried 2014-08-13 17:17:52 UTC
Description of problem:

This seems to be https://bugzilla.redhat.com/show_bug.cgi?id=1090181 which claims it got fixed, but apparently not.

Install virt-manager and deps using yum.
Run virt-manager, it says "python requires additional software, Additional software is required, libvirt-daemon-config-network"
Obviously this should be a dependency that gets installed at install time, but when you run the program.

Version-Release number of selected component (if applicable):

F20 with virt-manager-1.0.1-3.fc20

How reproducible:

see above

Steps to Reproduce:
1. yum install virt-manager
2. run virt-manager
3.

Actual results:

requires additional software install

Expected results:

deps installed at install time, not run time

Additional info:

Comment 1 Cole Robinson 2014-08-15 15:22:35 UTC
Thanks for the report, but libvirt-daemon-config-network is not strictly a virt-manager requirement, which is why we don't have a hard RPM dependency and instead recommend at run time. If you know what you are doing, you can cancel the run time package install and use virt-manager just fine connecting to a remote machine for example.

And this isn't just academic, multiple people complained about this which is what prompted the change. If this were debian/ubuntu we'd do something like Suggests: libvirt-daemon-config-network but that's not an option in Fedora. So this is NOTABUG


Note You need to log in before you can comment on or make changes to this bug.