Bug 1129930 - fail to assign correct order for the boot device in seabios as we specified the bootindex in qemu-kvm cli(under the same virtio-scsi-pci)
Summary: fail to assign correct order for the boot device in seabios as we specified t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: seabios
Version: 6.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Markus Armbruster
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1096560
Blocks: 1153397 1159926
TreeView+ depends on / blocked
 
Reported: 2014-08-14 02:50 UTC by Jun Li
Modified: 2015-07-22 07:01 UTC (History)
18 users (show)

Fixed In Version: seabios-0.6.1.2-29.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1096560
Environment:
Last Closed: 2015-07-22 07:01:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1355 normal SHIPPED_LIVE seabios enhancement update 2015-07-20 17:59:33 UTC

Comment 1 Jun Li 2014-08-14 02:55:39 UTC
Test it on rhel 6, steps as followings:

1.boot guests using following cli:
/usr/libexec/qemu-kvm -m 2G \
-device virtio-scsi-pci,id=scsi0 \
-drive file=/mnt/windows_img/win2012-64-virtio.raw,if=none,id=disk1,format=raw,snapshot=on \
-device scsi-hd,drive=disk1,id=sys-disk1,scsi-id=100,lun=0,bootindex=0 \
-boot menu=on -monitor stdio -vnc :2 \
-drive file=/mnt/linux_img/RHEL-Server-7.0-64.raw,if=none,id=disk2,snapshot=on \
-device scsi-hd,drive=disk2,id=sys-disk2,scsi-id=0,lun=0,bootindex=3 -S

2.check the boot order in seabios.
Press F12 for boot menu.

Actual results:
sys-disk2 is the first disk and sys-disk1 is the second disk when press F12.
Such as:
1. virtio-scsi Drive QEMU QEMU HARDDISK 1.5.
2. virtio-scsi Drive QEMU QEMU HARDDISK 1.5.
...

Expected results:
the order of the boot device in seabios should the same to we specified the bootindex in qemu-kvm command line.


Version of components:
# rpm -qa|grep qemu-kvm && rpm -qa|grep seabios
qemu-kvm-debuginfo-0.12.1.2-2.436.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.436.el6.x86_64
qemu-kvm-0.12.1.2-2.436.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64

Comment 10 Jeff Nelson 2014-12-23 19:36:20 UTC
Fix included in seabios-0.6.1.2-29.el6

Comment 12 langfang 2015-02-26 07:15:40 UTC
Reproduce this bug as follow version:
Host
# uname -r
2.6.32-539.el6.x86_64
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-0.12.1.2-2.448.el6.x86_64
# rpm -q seabios
seabios-0.6.1.2-28.el6.x86_64

Steps
1.Boot guest with 

 ..-device virtio-scsi-pci,id=scsi0 -drive file=/home/rhel6.6.raw,if=none,id=disk1,format=raw -device scsi-hd,drive=disk1,id=sys-disk1,scsi-id=100,lun=0,bootindex=0 -boot menu=on -monitor stdio -vnc :2 -drive file=/home/win8-64-virtio.raw,if=none,id=disk2 -device scsi-hd,drive=disk2,id=sys-disk2,scsi-id=0,lun=0,bootindex=3...


Results: guest boot up from the "bootindex=3" imag.

Verify this bug as follow version.

Host
# uname -r
2.6.32-539.el6.x86_64
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-0.12.1.2-2.448.el6.x86_64
# rpm -q seabios
seabios-0.6.1.2-29.el6.x86_64


Steps as same as reproduce

Resutls:

Guest boot up from "bootindex=0" imag, work well


According to above test , this bug has been fixed.

Comment 16 errata-xmlrpc 2015-07-22 07:01:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1355.html


Note You need to log in before you can comment on or make changes to this bug.