Bug 1130026 - FreeSpaceCriticalLowInGB variable takes negative values
Summary: FreeSpaceCriticalLowInGB variable takes negative values
Keywords:
Status: CLOSED DUPLICATE of bug 1130030
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-config
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Allon Mureinik
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 08:15 UTC by Ori Gofen
Modified: 2016-02-10 19:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 12:54:43 UTC
oVirt Team: Storage


Attachments (Terms of Use)

Description Ori Gofen 2014-08-14 08:15:12 UTC
Description of problem:
FreeSpaceCriticalLowInGB is a flag that warns the user when a domain has reached threshold level and prevent from creating new disks,however, this variable needs to unsigned because we do not want it to take negative values.

this is the default flag state:

root@ovirt-gofen-1 ~ # engine-config -g FreeSpaceCriticalLowInGB      
FreeSpaceCriticalLowInGB: 5 version: general

now I'm forcing FreeSpaceCriticalLow to be -3:

root@ovirt-gofen-1 ~ # engine-config -s FreeSpaceCriticalLowInGB=-3

check that the value is kept:

root@ovirt-gofen-1 ~ # engine-config -g FreeSpaceCriticalLowInGB   
FreeSpaceCriticalLowInGB: -3 version: general

Version-Release number of selected component (if applicable):
rc1

How reproducible:
100%

Steps to Reproduce:
1.engine-config -s FreeSpaceCriticalLowInGB=NEGATIVE_VALUE
2.restart engine

Actual results:
domain's has invalid free space threshold

Expected results:
domain's free space threshold > 0

Additional info:

Comment 1 Aharon Canan 2014-08-14 12:54:43 UTC
please check 1130026
This was opened as dup by mistake.

*** This bug has been marked as a duplicate of bug 1130030 ***


Note You need to log in before you can comment on or make changes to this bug.