Bug 1130215 - Foreman does not allow the installer to specify an alternative Fedora (EPEL) repository.
Summary: Foreman does not allow the installer to specify an alternative Fedora (EPEL) ...
Keywords:
Status: CLOSED DUPLICATE of bug 1130219
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL: https://trello.com/c/Dmd7bKlx/84-need...
Whiteboard: pre-MVP
Depends On:
Blocks: 1108193 1128481
TreeView+ depends on / blocked
 
Reported: 2014-08-14 14:46 UTC by John Williams
Modified: 2016-04-26 17:08 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-10 12:54:30 UTC


Attachments (Terms of Use)

Description John Williams 2014-08-14 14:46:15 UTC
Description of problem:
When attempting to install foreman, the installer would timeout trying to download packages from Fedora (epel) repository. Attempts to setup an internal repo in /etc/yum.repos.d were overwritten by the foreman installer thus the foreman installer would never work correctly

How reproducible:
Immediately reproducible. 

Steps to Reproduce:
1.  Create a eple repo file pointing to an internal repo and watch foreman overwrite it. 


Actual results:
Files are overwritten. 

Expected results:
Should be able to use an alternative epel repo.

Comment 3 arkady kanevsky 2014-09-08 22:20:36 UTC
If https://bugzilla.redhat.com/show_bug.cgi?id=1130219 is fixed then this bug can be closed without fixing. Meanwhile we need this as a workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1130219.

Comment 4 arkady kanevsky 2014-09-10 12:54:30 UTC
With Epel repo not needed as stated in https://bugzilla.redhat.com/show_bug.cgi?id=1130219. this bug is closed. https://bugzilla.redhat.com/show_bug.cgi?id=1130219 must be fixed.

*** This bug has been marked as a duplicate of bug 1130219 ***


Note You need to log in before you can comment on or make changes to this bug.