Bug 1130219 - Foreman should not generate epel.repo file as part of foreman_installer.sh
Summary: Foreman should not generate epel.repo file as part of foreman_installer.sh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: foreman-installer
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: z1
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard: pre-MVP
: 1130215 (view as bug list)
Depends On:
Blocks: 1108193 1128481
TreeView+ depends on / blocked
 
Reported: 2014-08-14 14:55 UTC by John Williams
Modified: 2016-04-27 03:42 UTC (History)
15 users (show)

Fixed In Version: foreman-installer-1.6.0-0.2.RC1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 13:26:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description John Williams 2014-08-14 14:55:32 UTC
Description of problem: Foreman requires packages be downloaded from Fedora (epel) repository.  Rather than requiring the packages be downloaded, foreman should include these packages as part of their installation bundle. 

How reproducible:
Required Packages are not included with foreman installation bundle.

Comment 3 Lon Hohberger 2014-08-19 13:44:19 UTC
Do we know the list of packages that are being grabbed from EPEL?

The RHEL OSP installer should not be enabling EPEL per default.

Comment 4 Alan Pevec 2014-08-20 09:35:00 UTC
(In reply to Lon Hohberger from comment #3)
> The RHEL OSP installer should not be enabling EPEL per default.

Not sure how machines are provisioned but it is documented[1] to set yum priorities for RHOS repos, so RHOS should always win.
Please provide /etc/yum.repos.d/ folder.

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Installation_and_Configuration_Guide/chap-Prerequisites.html#Red_Hat_OpenStack_Repository_Configuration

Comment 6 Mike Burns 2014-09-09 01:17:27 UTC
Can you please provide this information?  We won't enable EPEL by default.  Everything needed for RHEL-OSP installer should be included in RHN/CDN. 

(In reply to Lon Hohberger from comment #3)
> Do we know the list of packages that are being grabbed from EPEL?
> 
> The RHEL OSP installer should not be enabling EPEL per default.

Comment 7 John Williams 2014-09-09 20:15:39 UTC
This bug is related to the foreman_installer.sh script.   When the script runs, the script generates an epel.repo file in /etc/yum.repos.d which our network proxy blocks.  Thus we see the error shown below.   I originally assumed we needed the repo and modified the /usr/share/foreman-installer/modules/foreman/manifests/install/repos/extra.pp file to match our needs.  However, upon inspection, I just ran a test where I modified the extra.pp file by removing the generate_epel call line (second or third line in the file, if I recall correctly).  With this line removed, the foreman_installer.sh script does not generate the epel.repo file and appears to run fine. 


Notice: /Stage[main]/Foreman::Install::Repos::Extra/Yumrepo[epel]/ensure: created
Info: changing mode of /etc/yum.repos.d/epel.repo from 600 to 644
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list puppet-server' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
Error: /Stage[main]/Puppet::Server::Install/Package[puppet-server]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list puppet-server' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
Notice: /Stage[main]/Foreman::Config::Enc/File[/var/lib/puppet/yaml]: Dependency Package[puppet-server] has failures: true
Warning: /Stage[main]/Foreman::Config::Enc/File[/var/lib/puppet/yaml]: Skipping because of failed dependencies
Notice: /Stage[main]/Foreman_proxy::Proxydns/Dns::Zone[121.168.192.in-addr.arpa]/Concat_fragment[dns_zones+10_121.168.192.in-addr.arpa.dns]/content: content changed '' to 'zone "121.168.192.in-addr.arpa" {
    type master;
    file "/var/named/dynamic/db.121.168.192.in-addr.arpa";
    update-policy {
            grant rndc-key zonesub ANY;
    };
};
'
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list foreman-proxy' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
Error: /Stage[main]/Foreman_proxy::Install/Package[foreman-proxy]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list foreman-proxy' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again.

Comment 8 John Williams 2014-09-09 20:15:39 UTC
This bug is related to the foreman_installer.sh script.   When the script runs, the script generates an epel.repo file in /etc/yum.repos.d which our network proxy blocks.  Thus we see the error shown below.   I originally assumed we needed the repo and modified the /usr/share/foreman-installer/modules/foreman/manifests/install/repos/extra.pp file to match our needs.  However, upon inspection, I just ran a test where I modified the extra.pp file by removing the generate_epel call line (second or third line in the file, if I recall correctly).  With this line removed, the foreman_installer.sh script does not generate the epel.repo file and appears to run fine. 


Notice: /Stage[main]/Foreman::Install::Repos::Extra/Yumrepo[epel]/ensure: created
Info: changing mode of /etc/yum.repos.d/epel.repo from 600 to 644
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list puppet-server' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
Error: /Stage[main]/Puppet::Server::Install/Package[puppet-server]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list puppet-server' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
Notice: /Stage[main]/Foreman::Config::Enc/File[/var/lib/puppet/yaml]: Dependency Package[puppet-server] has failures: true
Warning: /Stage[main]/Foreman::Config::Enc/File[/var/lib/puppet/yaml]: Skipping because of failed dependencies
Notice: /Stage[main]/Foreman_proxy::Proxydns/Dns::Zone[121.168.192.in-addr.arpa]/Concat_fragment[dns_zones+10_121.168.192.in-addr.arpa.dns]/content: content changed '' to 'zone "121.168.192.in-addr.arpa" {
    type master;
    file "/var/named/dynamic/db.121.168.192.in-addr.arpa";
    update-policy {
            grant rndc-key zonesub ANY;
    };
};
'
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list foreman-proxy' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
Error: /Stage[main]/Foreman_proxy::Install/Package[foreman-proxy]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list foreman-proxy' returned 1: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again.

Comment 9 arkady kanevsky 2014-09-10 12:54:30 UTC
*** Bug 1130215 has been marked as a duplicate of this bug. ***

Comment 16 Chris Dearborn 2014-09-18 13:22:18 UTC
The fix for this bug has been verified by JT in the 9/12 puddle.

Comment 18 errata-xmlrpc 2014-10-01 13:26:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.