Bug 1130420 - password file already exists
Summary: password file already exists
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Matej Kollar
QA Contact: Lukas Pramuk
URL:
Whiteboard:
: 1130478 (view as bug list)
Depends On:
Blocks: stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-08-15 08:06 UTC by Tomas Lestach
Modified: 2017-02-23 21:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-25 13:16:25 UTC


Attachments (Terms of Use)

Description Tomas Lestach 2014-08-15 08:06:26 UTC
Description of problem:
When running 'hammer import all' multiple times
(1st pass to trigger repository sync, 2nd pass to create content views, ...)
the 'hammer import user' complaints about password file being already created.

Since this is a recommended use case, hammer import should count with that and shall not complain.


Suggested approach:
If password file already exists, just append eventual new lines.
(in 99% cases all users will be created during the 1st pass and no append will happen anyway.)

Comment 2 Matej Kollar 2014-08-15 10:46:44 UTC
*** Bug 1130478 has been marked as a duplicate of this bug. ***

Comment 3 Matej Kollar 2014-08-15 10:49:24 UTC
Alternate proposal:

It would be nice if ".<n>" would be appended for least natural n such that 
desired filename does not exist in case requested file exists.

This solution might be proffered as simply appending existing csv (or any other file) might lead to some complications (say in case users were deleted and re-imported, there will be two entries for the same user in single file).

Comment 5 Tomas Lestach 2014-08-25 13:16:25 UTC
Actually this is no issue to 'hammer import all' command, closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.