Bug 1130432 - [abrt] dnf: locale.py:166:_group:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)
Summary: [abrt] dnf: locale.py:166:_group:UnicodeDecodeError: 'ascii' codec can't deco...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a2bec85ae32fb055bcd45393e28...
Keywords:
: 1136036 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 08:27 UTC by Pavel Chalyi
Modified: 2014-09-23 04:40 UTC (History)
6 users (show)

Fixed In Version: dnf-0.6.1-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-23 04:40:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.98 KB, text/plain)
2014-08-15 08:27 UTC, Pavel Chalyi
no flags Details
File: environ (2.41 KB, text/plain)
2014-08-15 08:27 UTC, Pavel Chalyi
no flags Details

Description Pavel Chalyi 2014-08-15 08:27:24 UTC
Version-Release number of selected component:
dnf-0.5.5-1.fc22

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python -OO /usr/bin/dnf repolist
dso_list:       python-libs-2.7.8-3.fc22.x86_64
executable:     /usr/bin/dnf
kernel:         3.16.0-1.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
locale.py:166:_group:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1053, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/repolist.py", line 124, in run
    ui_num = _num2ui_num(num)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/repolist.py", line 44, in _num2ui_num
    return ucd(locale.format("%d", num, True))
  File "/usr/lib64/python2.7/locale.py", line 196, in format
    return _format(percent, value, grouping, monetary, *additional)
  File "/usr/lib64/python2.7/locale.py", line 217, in _format
    formatted, seps = _group(formatted, monetary=monetary)
  File "/usr/lib64/python2.7/locale.py", line 166, in _group
    left_spaces + thousands_sep.join(groups) + right_spaces,
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)

Local variables in innermost frame:
conv: {'mon_decimal_point': '.', 'int_frac_digits': 2, 'p_sep_by_space': 1, 'frac_digits': 2, 'thousands_sep': '\xc2\xa0', 'n_sign_posn': 1, 'decimal_point': ',', 'int_curr_symbol': 'RUB ', 'n_cs_precedes': 0, 'p_sign_posn': 1, 'mon_thousands_sep': '\xc2\xa0', 'negative_sign': '-', 'currency_symbol': '\xd1\x80\xd1\x83\xd0\xb1', 'n_sep_by_space': 1, 'mon_grouping': [3, 3, 0], 'p_cs_precedes': 0, 'positive_sign': '', 'grouping': [3, 3, 0]}
thousands_sep: '\xc2\xa0'
interval: 3
left_spaces: u''
monetary: False
s: ''
groups: [u'42', u'046']
right_spaces: ''
grouping: [3, 3, 0]

Potential duplicate: bug 1115076

Comment 1 Pavel Chalyi 2014-08-15 08:27:27 UTC
Created attachment 927014 [details]
File: backtrace

Comment 2 Pavel Chalyi 2014-08-15 08:27:28 UTC
Created attachment 927015 [details]
File: environ

Comment 3 Honza Silhan 2014-08-15 09:02:24 UTC
Hi, thanks for the report. I will take a look.

Comment 4 Honza Silhan 2014-08-25 09:18:20 UTC
Fixed in the upstream.

Comment 5 Honza Silhan 2014-09-02 19:06:23 UTC
*** Bug 1136036 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2014-09-04 15:49:37 UTC
dnf-0.6.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.1-1.fc21

Comment 7 Fedora Update System 2014-09-06 01:00:05 UTC
Package dnf-0.6.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10199/dnf-0.6.1-1.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-09-23 04:40:22 UTC
dnf-0.6.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.