Bug 1136036 - [abrt] dnf: locale.py:166:_group:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)
Summary: [abrt] dnf: locale.py:166:_group:UnicodeDecodeError: 'ascii' codec can't deco...
Status: CLOSED DUPLICATE of bug 1130432
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a2bec85ae32fb055bcd45393e28...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-01 13:35 UTC by Michal Kovarik
Modified: 2014-09-02 19:06 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-09-02 19:06:23 UTC


Attachments (Terms of Use)
File: backtrace (1.96 KB, text/plain)
2014-09-01 13:35 UTC, Michal Kovarik
no flags Details
File: environ (1.86 KB, text/plain)
2014-09-01 13:35 UTC, Michal Kovarik
no flags Details

Description Michal Kovarik 2014-09-01 13:35:17 UTC
Description of problem:
run 'dnf repolist' with LANG=cs_CZ.utf8

Version-Release number of selected component:
dnf-0.6.0-1.fc21

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python -OO /bin/dnf repolist
dso_list:       python-libs-2.7.8-4.1.fc21.x86_64
executable:     /bin/dnf
kernel:         3.16.1-301.mst.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
locale.py:166:_group:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1072, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/repolist.py", line 127, in run
    ui_num = _num2ui_num(num)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/repolist.py", line 47, in _num2ui_num
    return ucd(locale.format("%d", num, True))
  File "/usr/lib64/python2.7/locale.py", line 196, in format
    return _format(percent, value, grouping, monetary, *additional)
  File "/usr/lib64/python2.7/locale.py", line 217, in _format
    formatted, seps = _group(formatted, monetary=monetary)
  File "/usr/lib64/python2.7/locale.py", line 166, in _group
    left_spaces + thousands_sep.join(groups) + right_spaces,
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)

Local variables in innermost frame:
conv: {'mon_decimal_point': ',', 'int_frac_digits': 2, 'p_sep_by_space': 1, 'frac_digits': 2, 'thousands_sep': '\xc2\xa0', 'n_sign_posn': 1, 'decimal_point': ',', 'int_curr_symbol': 'CZK ', 'n_cs_precedes': 0, 'p_sign_posn': 1, 'mon_thousands_sep': '\xc2\xa0', 'negative_sign': '-', 'currency_symbol': 'K\xc4\x8d', 'n_sep_by_space': 1, 'mon_grouping': [3, 3, 0], 'p_cs_precedes': 0, 'positive_sign': '', 'grouping': [3, 3, 0]}
thousands_sep: '\xc2\xa0'
interval: 3
left_spaces: u''
monetary: False
s: ''
groups: [u'42', u'290']
right_spaces: ''
grouping: [3, 3, 0]

Potential duplicate: bug 1115076

Comment 1 Michal Kovarik 2014-09-01 13:35:20 UTC
Created attachment 933408 [details]
File: backtrace

Comment 2 Michal Kovarik 2014-09-01 13:35:21 UTC
Created attachment 933409 [details]
File: environ

Comment 3 Parag Nemade 2014-09-01 13:55:49 UTC
On dnf-0.6.1, the command "LANG=cs_CZ.utf8 sudo dnf repolist" ran fine.

Comment 4 Michal Kovarik 2014-09-02 09:36:51 UTC
yes, I can confirm that it's fixed in dnf-0.6.1-1.fc21.noarch

Comment 5 Honza Silhan 2014-09-02 19:06:23 UTC

*** This bug has been marked as a duplicate of bug 1130432 ***


Note You need to log in before you can comment on or make changes to this bug.