Bug 1130655 - [abrt] youtube-dl: vimeo.py:266:<genexpr>:ValueError: invalid literal for int() with base 10: 'base'
Summary: [abrt] youtube-dl: vimeo.py:266:<genexpr>:ValueError: invalid literal for int...
Keywords:
Status: CLOSED DUPLICATE of bug 1128438
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:6dddc97066777f9d2dc8340380c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 19:30 UTC by Alexandros
Modified: 2014-09-07 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-07 10:41:20 UTC


Attachments (Terms of Use)
File: backtrace (1.45 KB, text/plain)
2014-08-15 19:30 UTC, Alexandros
no flags Details

Description Alexandros 2014-08-15 19:30:21 UTC
Description of problem:
I was trying to download a video from www.vimeo.com and it crashed with no success. 

This is the output of the command:

# youtube-dl -v http://vimeo.com/87457434
[debug] System config: ['--prefer-free-formats']
[debug] User config: []
[debug] Command-line args: ['-v', 'http://vimeo.com/87457434']
[debug] Encodings: locale UTF-8, fs UTF-8, out UTF-8, pref UTF-8
[debug] youtube-dl version 2014.07.25.1
[debug] Python version 2.7.5 - Linux-3.15.8-200.fc20.x86_64-x86_64-with-fedora-20-Heisenbug
[debug] Proxy map: {}
[vimeo] 87457434: Downloading webpage
[vimeo] 87457434: Extracting information
[vimeo] 87457434: Downloading webpage
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/bin/youtube-dl/__main__.py", line 18, in <module>
  File "/bin/youtube-dl/youtube_dl/__init__.py", line 889, in main
  File "/bin/youtube-dl/youtube_dl/__init__.py", line 879, in _real_main
  File "/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1052, in download
  File "/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 516, in extract_info
  File "/bin/youtube-dl/youtube_dl/extractor/common.py", line 169, in extract
  File "/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in _real_extract
  File "/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in <genexpr>
ValueError: invalid literal for int() with base 10: 'base'

Version-Release number of selected component:
youtube-dl-2014.07.25.1-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        python /bin/youtube-dl --verbose http://vimeo.com/87457434
dso_list:       python-libs-2.7.5-13.fc20.x86_64
executable:     /bin/youtube-dl
kernel:         3.15.8-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
vimeo.py:266:<genexpr>:ValueError: invalid literal for int() with base 10: 'base'

Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/bin/youtube-dl/__main__.py", line 18, in <module>
    youtube_dl.main()
  File "/bin/youtube-dl/youtube_dl/__init__.py", line 889, in main
    _real_main(argv)
  File "/bin/youtube-dl/youtube_dl/__init__.py", line 879, in _real_main
    retcode = ydl.download(all_urls)
  File "/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1052, in download
    self.extract_info(url)
  File "/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 516, in extract_info
    ie_result = ie.extract(url)
  File "/bin/youtube-dl/youtube_dl/extractor/common.py", line 169, in extract
    return self._real_extract(url)
  File "/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in _real_extract
    _, video_thumbnail = sorted((int(width), t_url) for (width, t_url) in video_thumbs.items())[-1]
  File "/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in <genexpr>
    _, video_thumbnail = sorted((int(width), t_url) for (width, t_url) in video_thumbs.items())[-1]
ValueError: invalid literal for int() with base 10: 'base'

Local variables in innermost frame:
.0: <listiterator object at 0x253a910>
width: u'base'
t_url: u'http://i.vimeocdn.com/video/466346912'

Potential duplicate: bug 1128438

Comment 1 Alexandros 2014-08-15 19:30:24 UTC
Created attachment 927240 [details]
File: backtrace

Comment 2 Till Maas 2014-09-07 10:41:20 UTC

*** This bug has been marked as a duplicate of bug 1128438 ***


Note You need to log in before you can comment on or make changes to this bug.