Bug 1128438 - [abrt] youtube-dl: vimeo.py:266:<genexpr>:ValueError: invalid literal for int() with base 10: 'base'
Summary: [abrt] youtube-dl: vimeo.py:266:<genexpr>:ValueError: invalid literal for int...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:6dddc97066777f9d2dc8340380c...
: 1130655 1130757 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 13:03 UTC by Matteo Settenvini
Modified: 2014-09-25 00:16 UTC (History)
6 users (show)

Fixed In Version: youtube-dl-2014.08.29-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 22:21:36 UTC


Attachments (Terms of Use)
File: backtrace (1.48 KB, text/plain)
2014-08-10 13:03 UTC, Matteo Settenvini
no flags Details
File: environ (2.72 KB, text/plain)
2014-08-10 13:03 UTC, Matteo Settenvini
no flags Details

Description Matteo Settenvini 2014-08-10 13:03:30 UTC
Description of problem:
Trying to download any vimeo video.

Version-Release number of selected component:
youtube-dl-2014.07.25.1-1.fc21

Additional info:
reporter:       libreport-2.2.3
cmdline:        python /usr/bin/youtube-dl http://vimeo.com/90442971
dso_list:       python-libs-2.7.8-3.fc21.x86_64
executable:     /usr/bin/youtube-dl
kernel:         3.16.0-1.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
vimeo.py:266:<genexpr>:ValueError: invalid literal for int() with base 10: 'base'

Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
    youtube_dl.main()
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 889, in main
    _real_main(argv)
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 879, in _real_main
    retcode = ydl.download(all_urls)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1052, in download
    self.extract_info(url)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 516, in extract_info
    ie_result = ie.extract(url)
  File "/usr/bin/youtube-dl/youtube_dl/extractor/common.py", line 169, in extract
    return self._real_extract(url)
  File "/usr/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in _real_extract
    _, video_thumbnail = sorted((int(width), t_url) for (width, t_url) in video_thumbs.items())[-1]
  File "/usr/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in <genexpr>
    _, video_thumbnail = sorted((int(width), t_url) for (width, t_url) in video_thumbs.items())[-1]
ValueError: invalid literal for int() with base 10: 'base'

Local variables in innermost frame:
.0: <listiterator object at 0x7f411c4f4850>
width: u'base'
t_url: u'http://i.vimeocdn.com/video/469646633'

Comment 1 Matteo Settenvini 2014-08-10 13:03:33 UTC
Created attachment 925502 [details]
File: backtrace

Comment 2 Matteo Settenvini 2014-08-10 13:03:35 UTC
Created attachment 925503 [details]
File: environ

Comment 3 Till Maas 2014-09-07 10:41:15 UTC
*** Bug 1130757 has been marked as a duplicate of this bug. ***

Comment 4 Till Maas 2014-09-07 10:41:20 UTC
*** Bug 1130655 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2014-09-07 12:24:31 UTC
youtube-dl-2014.08.29-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-10058/youtube-dl-2014.08.29-1.fc20

Comment 6 Fedora Update System 2014-09-07 12:24:48 UTC
youtube-dl-2014.08.29-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-10001/youtube-dl-2014.08.29-1.fc21

Comment 7 Fedora Update System 2014-09-07 12:24:56 UTC
youtube-dl-2014.08.29-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2014-10036/youtube-dl-2014.08.29-1.fc19

Comment 8 Fedora Update System 2014-09-07 12:25:02 UTC
youtube-dl-2014.08.29-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2341/youtube-dl-2014.08.29-1.el7

Comment 9 Fedora Update System 2014-09-09 22:21:36 UTC
youtube-dl-2014.08.29-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-09-12 14:27:40 UTC
youtube-dl-2014.08.29-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-09-23 04:46:18 UTC
youtube-dl-2014.08.29-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-09-25 00:16:16 UTC
youtube-dl-2014.08.29-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.