Bug 113074 - parted cannot resize ext3 partition
Summary: parted cannot resize ext3 partition
Status: CLOSED DUPLICATE of bug 90894
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: parted   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-08 00:59 UTC by Robert Locke
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Locke 2004-01-08 00:59:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Attempting to resize an ext3 partition (the root partition) created at
install time by Disk Druid

Version-Release number of selected component (if applicable):
parted-1.6.3-29

How reproducible:
Always

Steps to Reproduce:
1.linux rescue (mounting partitions read-only)
2.parted /dev/hda
3.print (shows partition 6 going from 34920.734 to 73244.882
4.check 6 (this is the number of the root partition and is my last
partition - want to shrink it)
5.resize 6 34920.734 54082.808 (both check and resize generate the
following output)

    

Actual Results:  No Implementation: This ext2 filesystem has a rather
strange layout!  Parted
can't resize this (yet).


Expected Results:  Expect it to resize the partition

Additional info:

In reviewing some of the bug-parted mailing list, I noticed some
references to problems with a new version of the e2fsprogs library
being used by RHEL3 that breaks parted.

Comment 1 Matt Hansen 2004-02-08 09:07:23 UTC
I am seeing exactly the same problem with parted version 1.6.3-31. In
testing whether it's an ext3 issue - it shouldn't be as it's
supported, I converted the ext3 partition to ext2 and retried; but to
no avail.

Comment 2 Mike McCune 2004-06-10 20:36:01 UTC
I am getting the same error on an ext3 file system on RHEL3 with
Parted 1.6.3. I need parted as part as part of a recovery procedure.
Please let me know of any workarounds or fixes.

m.mccune@comcast.net

Comment 3 Need Real Name 2004-06-24 20:44:36 UTC
Same here.... no matter which version of parted I use, I get the same
issue. 

Comment 4 Jeremy Katz 2004-06-25 19:34:58 UTC

*** This bug has been marked as a duplicate of 90894 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:00:38 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.