Bug 90894 - (partedextlayout) Parted can't copy new install partition.
Parted can't copy new install partition.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
:
: 104836 113074 122803 128049 137793 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 01:53 EDT by Kenneth Corbin
Modified: 2007-11-30 17:10 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 15:53:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add ext_attr support to parted (896 bytes, patch)
2004-11-13 23:30 EST, Ian Burrell
no flags Details | Diff

  None (edit)
Description Kenneth Corbin 2003-05-15 01:53:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have two Redhat partition, a small boot parition in hdb1 and the normal Linux
system in hdb3  (hda is a DVD player).   Backup strategy is to boot to the small
backup parition and use parted to copy the main Linux parition to a separate
disk (hdd).   This worked find in Redhat 7.3.   It continued to work when I
reinstalled Redhat 9 in the boot partition, but it quite working when I
installed Redhat 9 in the main linux partition.   When it is asked to make the
copy, parted complains that....

This ext2 filesystem has a rather strange layout!  Parted can't resize this (yet)

A forced e2fsck -f /dev/hdb3 reports no errors, so I'm assuming that this is an
incompatibility between e2fsprogs and parted rather than a corrupted disk
partition.   Upgrading to parted 1.6.5 hasn't helped.

Version-Release number of selected component (if applicable):
Parted 1.6.3-11  E2fsprogs 1.32-6

How reproducible:
Always

Steps to Reproduce:
1.Run parted and create a partition slightly larger than the main Redhat linux
partition.
2. Ask to copy the main partition to the new one.

    

Actual Results:  This ext2 filesystem has a rather strange layout!  Parted can't
resize this (yet)


Expected Results:  It should have copied the partition

Additional info:
Comment 1 Jeremy Katz 2004-06-25 15:25:38 EDT
*** Bug 104836 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2004-06-25 15:35:00 EDT
*** Bug 113074 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2004-06-25 15:48:26 EDT
*** Bug 122803 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Clausen 2004-06-26 00:44:20 EDT
Unfortunately, Parted's ext2 support is a reimplementation of
e2fsprogs.  Ideally, we should switch over to using libe2fs, etc.
(which would require changes to libe2fs).  I'm happy to help
volunteers, but I don't have time to do this myself.
Comment 5 Günther Jakob 2004-06-30 03:11:09 EDT
I suggest that this bug (#90894) should be marked with 
priority "high" rather than "normal" for the following reasons:
Any ext2/ext3 filesystems created during the installation procedure 
of recent RedHat/Fedora Linux versions, which use the e2fsprogs for 
this task, cannot be resized, moved or copied anymore using parted. 
In other words: Parted can basically not be appplied to those 
partitions/filesystems anymore at all. Unfortunately, the utilities 
fdisk, resize2fs, etc. are not really alternatives (i.e. inconvenient 
to use) when you have to resize and move partitions and filesystems 
on a densely packed hard drive.

Regards,
Günther
Comment 6 Jeremy Katz 2004-07-16 16:31:26 EDT
*** Bug 128049 has been marked as a duplicate of this bug. ***
Comment 7 chris suttles 2004-07-17 06:09:27 EDT
I really dont have anything valuable to contribute to the resolution
of this bug, but I would like to know when a resolution is found. 

Thanks all, 

Chris
Comment 8 Jeremy Katz 2004-11-01 10:16:10 EST
*** Bug 137793 has been marked as a duplicate of this bug. ***
Comment 9 Ian Burrell 2004-11-13 23:30:34 EST
Created attachment 106657 [details]
Add ext_attr support to parted

I think the problem is that parted does not support the ext_attr feature used
for SELinux.  All the other features on my ext3 partitions are recognized by
parted.  This patch copies the EXT2_FEATURE_COMPAT_EXT_ATTR feature definition
from e2fsprogs and adds recognition of it.  I don't think there is any reason
for special handling of ext_attr.
Comment 10 Andrew Clausen 2004-11-20 18:47:03 EST
I think Parted needs special handling of ext_attr.

First, Parted's check won't like it, because it will find unreferenced
blocks.

Second, if it moves an EA block, all the inodes need to be updated.

It probably isn't very hard to fix these two problems, though.
Comment 11 J.P. Gonzalez 2004-12-02 09:39:46 EST
Additional issues:
When using Anaconda under Fedora Core 3 (and probably other versions),
not only the above mentioned problems happen, as well as the ones
mentioned in Bug 128049, but WINDOWS XP SETUP FROM THE CD STOPS
WORKING. It becomes impossible to run the setup program to
troubleshoot a windows installation that won't boot. If one tries to
boot from the CD, setup will hang after displaying "Setup is
inspecting your computer' hardware configuration".

After formatting the linux partitions with redhat 9 and reinstalling
FC3 without formatting the disks, all the above mentioned problems
went away. (I haven't checked the parted part, but I imagine it is
fixed as well).

For anyone with a dual boot FC3/XP configuration, I strongly advise
that you install the windows XP recovery console to allow for
additional recovery options in case of trouble. (normally you would
run it from the XP CD, which does not work with FC3 formatted drives)

Comment 12 Jens Hornung 2004-12-04 03:04:38 EST
I am working on FC2 (2.6.5-1.358), and using Partition Magic and
DriveImage (referenced as PQ tools below):
PQ tools works fine after initial install of the kernel, but after
installation of certain RPMs, the PQ tools does not recognize the root
partitions filesystem properly (Error #510; The version of the file
system is not supported). I found that these RPMs introduced the
ext_attr to the ext3 filesystem.
Are the ext_attr needed ?
I can remove the ext_attr easily the following way:
#debugfs -w /dev/hdb1
debugfs: feature -ext_attr
debugfs: q

Do I have a risk here ?

Regards
Jens
Comment 13 David Juran 2004-12-06 06:39:55 EST
Doesn't the extended attributes contain, among other things, ACL:s and
SELINUX security contexts? I would think twice before deciding I to
remove those things.
Comment 14 Need Real Name 2004-12-06 09:02:13 EST
I'm wondering what the point of a partition editor that can't resize
partitions is.
Comment 15 Jani Mikkonen 2005-02-07 10:20:12 EST
Im having this problem on redhat-release-3AS-12.3 (Fresh copy straight
from installation medias) and parted-1.6.3-29.3.

While trying to resize single big partition into smaller one, i get
error message saying:

Actual Results:  No Implementation: This ext2 filesystem has a rather
strange layout!  Parted can't resize this (yet).
Comment 16 Need Real Name 2005-02-07 15:20:54 EST
Mr Katz - is this bug likely to be fixed ever?
Comment 17 Ken A. 2005-04-01 13:11:55 EST
Partition Magic 8 doesn't like dir_index, resize_inode or ext_attr in
FC3 ext3 partitions. They must be removed before it will allow a resize.

You must disable SELINUX first.
edit /etc/selinux/config, and set SELINUX=disabled

Get e2fsprogs-1.37.tar.gz from sourceforge, compile and install it.

then do this (in single user mode!)

umount /dev/xxxx
debugfs -w /dev/xxxx -R "features ^resize_inode ^dir_index ^ext_attr"
e2fsck -y -f /dev/xxxx

Then reboot and run Partition Magic
Comment 19 Oscar A. Valdez 2005-04-29 11:46:57 EDT
Just to insist on Additional Comment #16 (2005-02-07):

Is this bug likely to be fixed ever?

And to paraphrase Additional Comment #14 (2004-12-06):

What is the point of a partition editor that can't resize
partitions?
Comment 20 Sven Neuhaus 2005-05-14 16:31:21 EDT
(In reply to comment #17)
> Partition Magic 8 doesn't like dir_index, resize_inode or ext_attr in
> FC3 ext3 partitions. They must be removed before it will allow a resize.

Will removing ext_attr delete any important information stored in the attributes
(i haven't changed any attributes on the filesystem in question myself)? Is it
possible to enable SELinux again after resizing the partition?
Comment 21 Markus Nicolussi 2005-09-12 19:18:52 EDT
hi! I just want to add that i have that not only on RedHat/Fedora, but up to now
since i try to utilize that tool also on SUSE until now to v1.6.24. seems to be
a general prob. not only of RH/FC --> i also interested if there is ANY chance
that that'll be fixed or do i have to buy probrietary software. A friend said
the russian paragon would do. Some specialist please tell us how the chances
are! I'm really desperate. It's extremely rare that i start to compile some SW
myselfe like i had to do with parted now to see if maybe not my distro screwed
up the tool ... ciao, nico.
Comment 22 Tim 2006-03-21 23:56:08 EST
This is a horrible horrible bug.  Many thanks to Comment #11 From J.P. Gonzalez
for explaining why my Windows XP CD and my Windows XP Pro CD would not install
on my computer.  I was ready to throw the whole computer out the window.  The
Windows disks would say "Setup is inspecting your hardware configuration" and
then I'd get a blank screen and the computer would never recover.  There weren't
many hints in that black screen, but I assumed the hardware was working because
I was able to install Fedora Core.  Fortunately a Google search found Mr.
Gonzalez' comment above that Fedora Core 3 had caused the whole problem.  When I
installed Red Hat 9 on that drive, removing every remnant of Fedora Core 3, the
Windows XP and Windows XP Pro installations worked fine.  It seems this a bug in
Fedora Core 3 colliding with a worse bug in Windows XP.  But of course Fedora
will get the blame even though Win XP is equally to blame.  Please fix this
problem as soon as possible.  It's very horrible.
Comment 23 Ian Burrell 2006-03-22 03:04:13 EST
The horrible bug is a completely different bug.  You probably mean #115980 or
#138419 (or at least some the issues reported in the bug since people jumping on
one bug).  This was by caused by FC3 using a different disk geometry than
Windows which confuses Windows.

My impression is that the problem has been fixed in FC4 and presumably in FC5. 
If you have a corrupted partition, wiping the drive and repartitioning it with
later Fedora versions or Windows should fix the problem.

Comment 24 David Cantrell 2006-09-13 12:19:50 EDT
Hi all,

I have not heard anything on this bug in a while and I'm wondering if it still
exists.

Can one of the reporters test with rawhide?  Or FC5?  If the problem has been
resolved, I'd like to close the bug.

Thanks.
Comment 25 Ian Burrell 2006-09-13 13:37:42 EDT
Parted 1.7.1 in FC5 or Rawhide does not have any support for ext3 filesystems
using ext_attr feature.  It will refuse to copy, resize, or move them with an
"File system has an incompatible feature enabled." error.
Comment 26 David Cantrell 2006-11-27 15:45:47 EST
I'd like to bring everyone on this bug report up to speed on where parted
currently sits with regard to the original reported issue.

Parted is currently at 1.8.0 which is mostly a bug fix release with some updates
to support new disk label types and partition IDs on new hardware (e.g., new
Macs).  We [the parted team] are working on parted 2.0 while continuing the 1.x
branch for bug fixes.

The problem originally reported in this report is definitely a bug, but not a
simple fix in libparted.  Currently, all of the filesystem code in libparted was
written from scratch.  It does not make use of any filesystem libraries
available (e2fsprogs, and so on).  This puts libparted at a severe disadvantage
when the filesystems introduce new features.  Our decision was to rewrite the
filesystem layer to use those libraries directly rather than add support as
needed to parted.  We can't guarantee that the latter method will work for
future filesystem versions, but we can guarantee a better level of compatibility
by using the libraries written by the same people that write the filesystems.

Our plan for parted 2.0 will add the support necessary to fix the problem
reported above.

Currently the _only_ tool that can resize ext3 filesystems is resize2fs
available in e2fsprogs.  While annoying, you can use resize2fs to resize the
filesystem and then use fdisk or parted to resize the partition boundary to
match the new filesystem size.  With parted 2.0, we'll be able to do this in one
step.
Comment 27 David Cantrell 2007-07-24 15:53:26 EDT
Closing as UPSTREAM.  We know about it upstream and are working on it.  No point
in tracking it as a RHEL or Fedora bug.
Comment 28 Need Real Name 2007-07-24 17:16:52 EDT
Please can you add the upstream bugzilla number so that commenters/reporters for
this bug can track it, as well as any future Fedora users that encounter the bug
before it is fixed.

Note You need to log in before you can comment on or make changes to this bug.