Bug 1130757 - [abrt] youtube-dl: vimeo.py:266:<genexpr>:ValueError: invalid literal for int() with base 10: 'base'
Summary: [abrt] youtube-dl: vimeo.py:266:<genexpr>:ValueError: invalid literal for int...
Keywords:
Status: CLOSED DUPLICATE of bug 1128438
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 19
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:6dddc97066777f9d2dc8340380c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-17 12:21 UTC by Richard Z.
Modified: 2014-09-07 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-07 10:41:15 UTC


Attachments (Terms of Use)
File: backtrace (1.73 KB, text/plain)
2014-08-17 12:21 UTC, Richard Z.
no flags Details
File: environ (2.60 KB, text/plain)
2014-08-17 12:21 UTC, Richard Z.
no flags Details

Description Richard Z. 2014-08-17 12:21:02 UTC
Description of problem:
youtube-dl http://www.whoi.edu/main/remus-sharkcam

[generic] remus-sharkcam: Requesting header
WARNING: Falling back on generic information extractor.
[generic] remus-sharkcam: Downloading webpage
[generic] remus-sharkcam: Extracting information
[vimeo] 101165012: Downloading webpage
[vimeo] 101165012: Extracting information
Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 889, in main
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 879, in _real_main
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1052, in download
...
...
...

Version-Release number of selected component:
youtube-dl-2014.07.25.1-1.fc19

Additional info:
reporter:       libreport-2.2.2
cmdline:        python /usr/bin/youtube-dl http://www.whoi.edu/main/remus-sharkcam
dso_list:       python-libs-2.7.5-13.fc19.i686
executable:     /usr/bin/youtube-dl
kernel:         3.14.15-100.fc19.i686.PAE
runlevel:       unknown
type:           Python
uid:            1000

Truncated backtrace:
vimeo.py:266:<genexpr>:ValueError: invalid literal for int() with base 10: 'base'

Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
    youtube_dl.main()
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 889, in main
    _real_main(argv)
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 879, in _real_main
    retcode = ydl.download(all_urls)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1052, in download
    self.extract_info(url)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 527, in extract_info
    return self.process_ie_result(ie_result, download, extra_info)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 571, in process_ie_result
    extra_info=extra_info)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 516, in extract_info
    ie_result = ie.extract(url)
  File "/usr/bin/youtube-dl/youtube_dl/extractor/common.py", line 169, in extract
    return self._real_extract(url)
  File "/usr/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in _real_extract
    _, video_thumbnail = sorted((int(width), t_url) for (width, t_url) in video_thumbs.items())[-1]
  File "/usr/bin/youtube-dl/youtube_dl/extractor/vimeo.py", line 266, in <genexpr>
    _, video_thumbnail = sorted((int(width), t_url) for (width, t_url) in video_thumbs.items())[-1]
ValueError: invalid literal for int() with base 10: 'base'

Local variables in innermost frame:
.0: <listiterator object at 0x8b7d10c>
width: u'base'
t_url: u'http://i.vimeocdn.com/video/483988416'

Potential duplicate: bug 1128438

Comment 1 Richard Z. 2014-08-17 12:21:06 UTC
Created attachment 927453 [details]
File: backtrace

Comment 2 Richard Z. 2014-08-17 12:21:08 UTC
Created attachment 927454 [details]
File: environ

Comment 3 Till Maas 2014-09-07 10:41:15 UTC

*** This bug has been marked as a duplicate of bug 1128438 ***


Note You need to log in before you can comment on or make changes to this bug.