Bug 1131151 - wget dependency is not described
Summary: wget dependency is not described
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: heat-cfntools
Version: 4.0
Hardware: All
OS: Linux
high
high
Target Milestone: z5
: 4.0
Assignee: Jeff Peeler
QA Contact: Amit Ugol
URL:
Whiteboard:
: 1136987 (view as bug list)
Depends On: 1130964
Blocks: 1136986 1136987 1138864 1138865 1140412 1147088
TreeView+ depends on / blocked
 
Reported: 2014-08-18 14:42 UTC by Steven Dake
Modified: 2016-04-26 17:50 UTC (History)
11 users (show)

Fixed In Version: heat-cfntools-1.2.6-4.el6
Doc Type: Bug Fix
Doc Text:
The heat-cfntools package was missing some dependencies. As a result, in some circumstances, installing the heat-cfntools package in an image would result in some of the features not working correctly, in particular, those requiring external commands, such as, curl. With this fix, these dependencies are now added to the package and the heat-cfntools features requiring external commands work correctly without having to install additional packages.
Clone Of: 1130964
: 1136986 1136987 1138864 1138865 1140412 (view as bug list)
Environment:
Last Closed: 2014-10-22 18:23:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1359430 None None None Never
Red Hat Product Errata RHBA-2014:1696 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix Advisory 2014-10-22 22:22:32 UTC

Description Steven Dake 2014-08-18 14:42:01 UTC
+++ This bug was initially created as a clone of Bug #1130964 +++

heat-cfntools uses 'wget' command in cfn_helper.py, but wget dependency is not described in spec file.
wget is not installed sometimes. (e.g. in the case of a minimum OS installation.) We should write it.

The following is the relevant section of the code.
* cfntools/cfn_helper.py
1066         url = 'http://169.254.169.254/openstack/2012-08-10/meta_data.json'
1067         if not os.path.exists(cache_path):
1068             CommandRunner('wget -O %s %s' % (cache_path, url)).run()
1069         try:

* heat-cfntools.spec
  8 Source0: https://pypi.python.org/packages/source/h/heat-cfntools/%{name}-%{version}.tar.gz
  9 
 10 BuildArch: noarch
 11 BuildRequires: python2-devel
 12 BuildRequires: python-setuptools
 13 BuildRequires: python-pbr >= 0.5.20
 14 
 15 Requires: python-boto >= 2.5.2
 16 Requires: python-psutil
 17 Requires: python-argparse
 18 
 19 %description

--- Additional comment from Yukinori Sagara on 2014-08-18 05:56:51 EDT ---

I missed to write version. I verified it on heat-cfntools-1.2.6-2.el6.src.rpm.

Comment 2 Steve Baker 2014-08-21 21:51:18 UTC
Adding upstream bug for consolidating on curl

Comment 4 Jeff Peeler 2014-09-05 20:42:26 UTC
*** Bug 1136987 has been marked as a duplicate of this bug. ***

Comment 6 Amit Ugol 2014-10-14 03:45:51 UTC
Nowadays cfn-tools needs curl as a dependency and not wget. Marking this as resolved. I cannot test the dependency tree since curl is a much more fundamental package (needed by yum) but installing it will not ask to install wget as a dependency.

Comment 8 errata-xmlrpc 2014-10-22 18:23:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1696.html


Note You need to log in before you can comment on or make changes to this bug.