Bug 1132094 - slapd.ldif olcFrontend missing important/required objectclass
Summary: slapd.ldif olcFrontend missing important/required objectclass
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openldap
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: Eduard Benes
URL:
Whiteboard:
Keywords: Patch
: 1132111 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-20 16:18 UTC by Louis Abel
Modified: 2015-08-17 15:28 UTC (History)
6 users (show)

(edit)
Due to a missing object-path information in the database front-end configuration, it was not possible to modify the front-end configuration by standard means. The objectClass information has been added, and the user now can modify the front-end configuration by standard means.
Clone Of:
(edit)
Last Closed: 2015-03-05 13:35:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0597 normal SHIPPED_LIVE openldap bug fix and enhancement update 2015-03-05 17:20:57 UTC
OpenLDAP ITS 7933 None None None Never
Red Hat Bugzilla 1132111 None CLOSED olcDatabase in olcFrontend attribute incorrect/faulty 2019-04-05 17:34 UTC

Internal Trackers: 1132111 1226600

Description Louis Abel 2014-08-20 16:18:11 UTC
Description of problem:

Current /usr/share/openldap-servers/slapd.ldif that mentions in the Frontend database is missing an important objectClass. This causes issues when trying to add specific attributes that would be done on the frontend olc database just as olcPasswordHash.

It currently reads:
...
dn: olcDatabase=frontend,cn=config
objectClass: olcDatabaseConfig
olcDatabase: frontend
...

It should be:

dn: olcDatabase=frontend,cn=config
objectClass: olcDatabaseConfig
objectClass: olcFrontendConfig
olcDatabase: frontend


Version-Release number of selected component (if applicable):
openldap-servers-2.4.39-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install openldap-servers
2. Attempt to modify olcDatabase={-1}Frontend adding olcPasswordHash or other applicable attributes


Actual results:
modifying entry "olcDatabase={-1}frontend,cn=config"
ldap_modify: Object class violation (65)
        additional info: attribute 'olcPasswordHash' not allowed

Expected results:
modifying entry "olcDatabase={-1}frontend,cn=config"
(No errors)

Additional info:
N/A

Comment 2 Jan Synacek 2014-09-08 11:39:51 UTC
Submitted as Upstream ITS #7933.

http://www.openldap.org/its/index.cgi/Incoming?id=7933;selectid=7933

Comment 3 Sebastian 2014-09-30 08:17:34 UTC
As Upstream has already fixed this (new issue link: http://www.openldap.org/its/index.cgi/Build?id=7933), when can one expect the fix to arrive in RHEL 7?

Comment 6 Jan Synacek 2014-11-28 11:47:54 UTC
*** Bug 1132111 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2015-03-05 13:35:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0597.html


Note You need to log in before you can comment on or make changes to this bug.