Bug 1132111 - olcDatabase in olcFrontend attribute incorrect/faulty
Summary: olcDatabase in olcFrontend attribute incorrect/faulty
Keywords:
Status: CLOSED DUPLICATE of bug 1132094
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openldap
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: David Spurek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-20 17:06 UTC by Louis Abel
Modified: 2015-06-02 15:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1226600 (view as bug list)
Environment:
Last Closed: 2014-11-28 11:47:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1132094 None None None Never

Internal Links: 1132094

Description Louis Abel 2014-08-20 17:06:30 UTC
Description of problem:

Modifications cannot be performed on the default olcDatabase={-1}Frontend due to the olcDatabase attribute being incorrect as opposed to the distinguished name. 

Default install shows:
dn: olcDatabase={-1}frontend
olcDatabase: frontend

Should be:
dn: olcDatabase={-1}frontend
olcDatabase: {-1}frontend

Version-Release number of selected component (if applicable):
openldap-servers-2.4.39-3.el7.x86_64

How reproducible:
On first installation of openldap-servers package/Always.

Steps to Reproduce:
1. Install openldap-servers
2. Attempt to modify olcDatabase={-1}Frontend

Actual results:
[root@library ldif]# ldapmodify -xWD "cn=config" -f ~/stuff 
Enter LDAP Password: 
modifying entry "olcDatabase={-1}frontend,cn=config"
ldap_modify: Naming violation (64)
        additional info: value of naming attribute 'olcDatabase' is not present in entry


Expected results:
modifying entry "olcDatabase={-1}frontend,cn=config"
(No errors)

Additional info:
This is corrected by manually editing /etc/openldap/slapd.d/cn\=config/olcDatabase\=\{-1\}frontend.ldif - Which is discouraged.

This is also similar to bug: 1132094, which states that the ldif is also missing an important objectClass.

Comment 2 Jan Synacek 2014-11-28 11:47:54 UTC

*** This bug has been marked as a duplicate of bug 1132094 ***

Comment 3 Matus Honek 2015-06-02 15:43:41 UTC
This bug is not actually a duplicate of BZ1132094 but rather a related one.
For more info on this bug see its clone BZ1226600.


Note You need to log in before you can comment on or make changes to this bug.