Bug 113245 - Unable to mount root filesystem
Unable to mount root filesystem
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-10 10:42 EST by Ted Kaczmarek
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-25 07:16:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Tra ball of configs and System.map's (800.00 KB, application/octet-stream)
2004-01-10 10:44 EST, Ted Kaczmarek
no flags Details

  None (edit)
Description Ted Kaczmarek 2004-01-10 10:42:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Been running 2.6.0-1.104smp with good success, tried out
kernel-smp-2.6.1-1.126 and it is unable to mount /root. It appears
to properly load the scsi driver but then fails. This is on a Fedora
Core 1 box that has the latest updates. Snippet of the two grub entries.

title Fedora Core (2.6.1-1.126smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.1-1.126smp ro root=/dev/sda7 acpi=on
        initrd /initrd-2.6.1-1.126smp.img
title Fedora Core (2.6.0-1.104smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.0-1.104smp ro root=LABEL=/ acpi=on
        initrd /initrd-2.6.0-1.104smp.img


Version-Release number of selected component (if applicable):
kernel-smp-2.6.1-1.126

How reproducible:
Always

Steps to Reproduce:
1.Install kernel-smp-2.6.1-1.126
2.Reboot choosing kernel-smp-2.6.1-1.126
3.
    

Actual Results:  Unable to mount root filesystem

Expected Results:  Boots properly like with 2.6.0-1.104smp.

Additional info:

The two System.map files are very different, I will attach the config
and system maps for both.

Hope this is useful.
Comment 1 Ted Kaczmarek 2004-01-10 10:44:38 EST
Created attachment 96876 [details]
Tra ball of configs and System.map's

Cheers and Happy New Year!!!
Comment 2 Arjan van de Ven 2004-01-10 12:13:08 EST
the biggest visible difference appears to be the root= line....
(System.map's are irrelevant for things like this, all they contain is
memory addresses of functions)
Comment 3 Ted Kaczmarek 2004-01-11 07:42:34 EST
Does the same thing with root=LABEL=/.
Comment 4 Ted Kaczmarek 2004-01-19 09:34:49 EST
Same thing happens with 2.6.1-1.131smp.

title Fedora Core (2.6.1-1.131smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.1-1.131smp ro root=LABEL=/ acpi=on
        initrd /initrd-2.6.1-1.131smp.img

2.6.0-1.104smp works fine.

title Fedora Core (2.6.0-1.104smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.0-1.104smp ro root=LABEL=/ acpi=on
        initrd /initrd-2.6.0-1.104smp.img

[root@inyoureyes boot]# ls -latr *2.6*.img
-rw-r--r--    1 root     root       339094 Dec 21 09:19
initrd-2.6.0-1.104smp.img
-rw-r--r--    1 root     root       326212 Jan 10 08:50
initrd-2.6.1-1.126smp.img
-rw-r--r--    1 root     root       323120 Jan 17 08:09
initrd-2.6.1-1.131smp.img

I will attempt to recompile add build the scsi and ext3 modules into
the kernel.

Comment 5 Ted Kaczmarek 2004-01-19 12:38:43 EST
With the ext3 and scsi support built into the kernel it does not have
this prolem. Also I am using the below statement in grub.
title Fedora Core (2.6.1-1.131smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.1-1.131smp-011904 ro root=/dev/sda7 acpi=on
        initrd /initrd-2.6.1-1.131smp.img

Hope this is useful.

Comment 6 Ted Kaczmarek 2004-01-19 18:25:49 EST
I tried installing kernel-smp-2.6.1-1.138, installing from yum I get
the below message.

[install: kernel-smp 2.6.1-1.138.i686]
Is this ok [y/N]: y
Running test transaction:
Test transaction complete, Success!
kernel-smp 100 % done 1/1
/dev/mapper/control: open failed: No such file or directory
Is device-mapper driver missing from kernel?
Command failed
Kernel Updated/Installed, checking for bootloader
Grub found - making this kernel the default
Installed:  kernel-smp 2.6.1-1.138.i686
Transaction(s) Complete

mkinitrd-3.5.15.1-2
device-mapper-1.00.07-1

This one also has the same problem as well, since I can boot when
compiling the support into the kernel it would appear that the img is
not loading one of the modules needed to mount /root. I'll leave that
to the experts :-)
Comment 7 Ted Kaczmarek 2004-01-25 07:16:52 EST
Bug #112623
Ok, this is definetly the root cause.  
Downgrading mkinitrd to mkinitrd-3.5.14-1 resolves the issue.

Thanks,
Ted

Note You need to log in before you can comment on or make changes to this bug.