Bug 11327 - Buttons should not display if you are not logged in
Buttons should not display if you are not logged in
Status: CLOSED DEFERRED
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.1r
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-09 10:59 EDT by Stephen Rasku
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-09 11:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2000-05-09 10:59:47 EDT
If you are not logged in, the buttons "Add Comment", "Add Me to CC List",
and "Remove Me from CC List" and the "Additional Comments" text box should
not be displayed since they can not be used until you log in anyways.

You could display a login button instead.
Comment 1 David Lawrence 2000-05-09 11:34:59 EDT
I will look into implementing this. Sounds like just writing more code to
accomplish the same thing that is currently happening :) But it may prove useful
none the less. The way Bugzilla is written here now is basically an all or
nothing deal. If you have special permission you can edit all aspects of a bug
report and if you dont then you can only add a comment, cc, etc. In the past if
one was not logged in and added a comment it wass logged as 'Anonymous' and was
undesirable if someone wanted to gain more information. So we changed it to
people must have an account to add any information. Talk has been done about
adding a fetaure which would allow each field of the report itself to be allowed
or disallowed for change. This is actually similar to how it used to be done
with an earlier version of bugzilla it was many times slowere since Bugzilla was
making 80+ database accesses per bug report. So now hopefully something will
change soon to better fine tune this process.
Comment 2 Stephen Rasku 2000-05-10 01:01:59 EDT
The reason that I would like this feature implemented is that I quite often
think that I am logged in when I'm not and I complain about not being able to
resolve, modify severity, etc...  This is exacerbated by the cookie problems
(see bug 9598) which mislead you to whether you are logged in or not.  I guess I
will get the hang of it and know that if I only see those three buttons, I will
know that I am not logged in.

Note You need to log in before you can comment on or make changes to this bug.