Bug 9598 - Have to login multiple times using Netscape 4.51
Have to login multiple times using Netscape 4.51
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
: 9703 10504 10856 11249 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-02-19 19:33 EST by Stephen Rasku
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-05-06 21:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2000-02-19 19:33:56 EST
At first I thought this was a cookie problem so I deleted all my redhat.com
cookies.  However, I had to login to enter a bug, login to commit the bug,
and login to enter a new bug.  It hasn't asked me again so far this session
but it will probably happen again.  I am reporting it as a new bug but
there seems to be a couple of related bugs:  bug #930 and bug #2351

P.S. It just asked me for my login to commit this bug.
Comment 1 David Lawrence 2000-02-28 12:53:59 EST
Please try quitting Netscape completely. Then edit ~/.netscape/cookies and
remove all instances of the lines that contain Bugzilla_login and
Bugzilla_logincookie. The re-run Netscape, connect to Bugzilla and re-login.
Please let me know if this fixes the problem for you.
Comment 2 Stephen Rasku 2000-03-01 02:10:59 EST
I did that and I was able to CC myself to some bugs without having to enter my
password.  However, I can't resolve this bug -- there's no button to allow me to
do this.  Is that related to this or is that another bug? Or is that the way its
supposed to work?
Comment 3 Stephen Rasku 2000-03-01 02:18:59 EST
Now I can see the resolution option.  However, I just had to login to report a
bug.  It seems very flaky.

P.S. It made me enter a password to add this comment.  I have a bugzilla account
on another server.  Could this affect it?
Comment 4 David Lawrence 2000-03-01 11:09:59 EST
Having other bugzilla accounts should not effect it since the lines in your
cookies file would have different server addresses as the first parameter. As
long as there are not two line containing

bugzilla.redhat.com     FALSE   /bugzilla/      FALSE   1877472623  \
Bugzilla_login  rc5tv@home.com


bugzilla.redhat.com     FALSE   /bugzilla/      FALSE   1877472623  \
Bugzilla_logincookie <some number>

then it should work.

One thing to make sure is to use the full domain name bugzilla.redhat.com such
as http://bugzilla.redhat.com/bugzilla when connecting because unfortunately




do not mean the same thing in your cookies file. I am working on trying to make
this work some way but it may be a limitation of netscape.

As for resolving bugs, only the reporter, the person that the bug is assigned to
and other privileged groups internal to red hat can make changes to a bug,
including resolving and reopening. You should be able to make changes to your
own bug since you are the reporter.
Comment 5 David Lawrence 2000-03-01 12:08:59 EST
I have not been able to replicate this on a stock red hat system running
netscape 4.51 and the newer 4.72. You may want to move your whole cookies file
to the side and try it again that way. I would be interested to know if that
makes a difference. You may also consider upgrading to 4.72 but I am not sure
that would make much difference in your case.
Comment 6 Stephen Rasku 2000-03-02 16:08:59 EST
Comment 7 Stephen Rasku 2000-03-02 21:38:59 EST
test 2 ...
Comment 8 Stephen Rasku 2000-03-02 21:53:59 EST
Moving the cookie file away worked.  I tried to "forget" my login, but that
didn't work.  However, when I re-removed my cookies file and clicked on the
login link from the query page then tried to add this comment, it asked me to
login again.

I guess I'll try and upgrade my Netscape.
Comment 9 Stephen Rasku 2000-03-02 22:14:59 EST
This is posted from Netscape 4.72.  I don't think that it's going to work
because the resolve buttons are not being displayed.  I haven't re-deleted the
cookies file.  The entire contents of the file are:

bugzilla.redhat.com     FALSE   /bugzilla/      FALSE   1877472733
Bugzilla_login  rc5tv@home.com
bugzilla.redhat.com     FALSE   /bugzilla/      FALSE   1877472733
Bugzilla_logincookie    99999
.netscape.com   TRUE    /usdl-bin       TRUE    952067385
.preferences.com        TRUE    /       FALSE   1267628397      PreferencesID
.netscape.com   TRUE    /       FALSE   1293840079      UIDC
Comment 10 Stephen Rasku 2000-03-02 22:15:59 EST
Hmmm, it worked but I can't resolve the bug because the button is not visible.
I don't want to do that quite yet, I'll see if the problem shows up again.
Comment 11 Stephen Rasku 2000-03-06 01:45:59 EST
Yeah, this bug is still open.  It displays my user ID at the top of the screen
but it says that I haven't logged in when I try and go to the query page.  I
also can't seen a resolve button at the bottom of this page even though I
created this bug.

P.S. It asked me for a password to enter this comment.
Comment 12 Stephen Rasku 2000-03-06 01:47:59 EST
OK, now I can see the resolve button.  Do I have a really short expiry time on
my cookie?
Comment 13 Stephen Rasku 2000-03-09 01:15:59 EST
OK, seems to be working now.
Comment 14 Stephen Rasku 2000-03-24 21:11:59 EST
This is happening again.  Maybe its a problem with expiring cookies?  This is
the entries for my Red Hat bugzilla cookies:

bugzilla.redhat.com	FALSE	/bugzilla/	FALSE	1877472830	Bugzilla_login
bugzilla.redhat.com	FALSE	/bugzilla/	FALSE	1877472830	Bugzilla_logincookie	99999

I don't know how to read all these fields.  Specifically, I don't know what the
2nd, 4th, and fifth field are for.  I think that the fifth field might be a
time-stamp but I don't know how to convert it to human-readable form.  Right
now, my email address is displayed at the top under "Login:".  I suspect that it
will ask me to login to submit this job.  If there's no message below, my
suspicion was was wrong and it accepted this comment.

Nope, my suspicion was right.  It asked me to login.  Why is it displaying my
e-mail address if it thinks I am not logged in?
Comment 15 Stephen Rasku 2000-03-24 21:20:59 EST
Since I logged the last comment, I've been correctly logged in.  I did a query
in between reporting that comment and this one.  This is driving me crazy!
Comment 16 Stephen Rasku 2000-03-24 21:21:59 EST
Since I logged the last comment, I've been correctly logged in.  I did a query
and added myself to the CC list to various bugs in between reporting that
comment and this one.  This is driving me crazy!
Comment 17 David Lawrence 2000-03-31 23:52:59 EST
*** Bug 9703 has been marked as a duplicate of this bug. ***
Comment 18 David Lawrence 2000-03-31 23:54:59 EST
*** Bug 10504 has been marked as a duplicate of this bug. ***
Comment 19 David Lawrence 2000-04-16 18:23:59 EDT
*** Bug 10856 has been marked as a duplicate of this bug. ***
Comment 20 David Lawrence 2000-05-06 21:19:59 EDT
*** Bug 11249 has been marked as a duplicate of this bug. ***
Comment 21 Stephen Rasku 2001-02-09 04:02:39 EST
I haven't seen this in a while.  Marking WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.