Bug 113291 - FLAC plugin should be included
FLAC plugin should be included
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gstreamer-plugins (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Colin Walters
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-12 01:09 EST by Phil Anderson
Modified: 2007-04-18 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-22 22:17:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updates spec file (12.34 KB, text/plain)
2004-01-12 02:40 EST, Phil Anderson
no flags Details

  None (edit)
Description Phil Anderson 2004-01-12 01:09:21 EST
The FLAC encoder and xmms plugin has been added into rawhide recently
(bug 100931 should probably be closed), but the gstreamer flac plugin
isn't there!  This is stopping sound-juicer from being able to rip to
FLAC files.
Comment 1 Phil Anderson 2004-01-12 01:37:47 EST
The FLAC plugin is part of the 0.6.3 and the 0.6.4 releases of
gstreamer, so (I'm guessing) all that is required is to
reconfigure/recompile with --with-flac or something like that.
Comment 2 Phil Anderson 2004-01-12 02:40:20 EST
Created attachment 96890 [details]
Updates spec file

This spec file will build the flac plugin, and also adds a few build
requirements (png-devel, flac-devel, libghttp-devel, libraw1394-devel).

I wasn't sure what version to put as the minimum for the above build
requirements, so I put the version in fedora core 1.
Comment 3 Phil Anderson 2004-01-12 06:29:21 EST
Note that the above spec solves the missing dependencies reported in
bugs 108478 109620 110017 111838 110666 which are all basically
duplicates of each other.

Note that I didn't add nasm to the requirements list, as it wasn't
required to build libgstqcam on my i386 machine.  I'm guessing this is
because Rawhide is on version 0.6.3-3 whereas RHEL 3 is using 0.6.0-14
which must require it to build.

Note You need to log in before you can comment on or make changes to this bug.