Bug 113360 - RHEL2.1: C shells can't be used in "at" jobs
Summary: RHEL2.1: C shells can't be used in "at" jobs
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: at   
(Show other bugs)
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 107566 116726
TreeView+ depends on / blocked
 
Reported: 2004-01-13 03:55 UTC by Jens Petersen
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 14:50:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:341 normal SHIPPED_LIVE Updated at package 2004-08-18 04:00:00 UTC
Red Hat Product Errata RHBA-2004:593 normal SHIPPED_LIVE Updated at package 2004-12-21 05:00:00 UTC

Description Jens Petersen 2004-01-13 03:55:10 UTC
Description of problem:
This is a duplicate of FC1 bug 109587 for RHEL3.

Version-Release number of selected component (if applicable):
at-3.1.8-46

How reproducible:
every time

Steps to Reproduce:
1. echo "ls" | SHELL=/bin/tcsh at
  
Actual results:
tcsh at job script uses Bourne syntax to set envvars.

Expected results:
Shouldn't create broken script for C shell users.

Additional info:
A fix is already in FC devel.

Comment 1 Jens Petersen 2004-01-13 04:04:57 UTC
Thanks for the report.  A fix for this is currently
being tested in FC Devel.

Comment 5 John Flanagan 2004-08-18 14:50:59 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-341.html


Comment 6 John Flanagan 2004-12-21 21:19:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-593.html



Note You need to log in before you can comment on or make changes to this bug.