Bug 109587 - at generates bad tcsh scripts
Summary: at generates bad tcsh scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: at
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Mike McLean
URL:
Whiteboard:
: 111386 117102 117276 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-09 21:20 UTC by Michael Fischer
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-13 03:42:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:593 normal SHIPPED_LIVE Updated at package 2004-12-21 05:00:00 UTC

Description Michael Fischer 2003-11-09 21:20:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
at generates a bad script when SHELL=/bin/tcsh.  It puts the correct
heading line #!/bin/tcsh into the script, but it puts /bin/sh-style
environment-setting commands into the script, e.g.
NNTPSERVER=news.yale.edu; export NNTPSERVER
This script of course fails when run.

If instead at is called with SHELL=/bin/sh, then it generates a
correct /bin/sh-style script which works correctly.

Version-Release number of selected component (if applicable):
at-3.1.8-46.1

How reproducible:
Always

Steps to Reproduce:
1.Set environment variable SHELL=/bin/tcsh
2.at now
3.at> whoami
4. ^D
5. Read email response.

    

Actual Results:  Email showing attemt to execute environment, e.g.,
NNTPSERVER=news.yale.edu: Command not found.
export: Permission denied.
...


Expected Results:  Email containing "mike' (the result of the "whoami"
command).

Additional info:

To see the script generated, try at 'now+1 hour'; then look in
/var/spool/at and examine the generated script.

Comment 1 David L. Crow 2003-11-11 20:41:15 UTC
Probably a dupe of 91233

Comment 2 Michael Fischer 2003-11-11 22:02:53 UTC
I agree.  Thanks for pointing this out to me.  I'm marking this as a
duplicate of 91233.

*** This bug has been marked as a duplicate of 91233 ***

Comment 3 Jens Petersen 2004-01-13 03:37:06 UTC
*** Bug 111386 has been marked as a duplicate of this bug. ***

Comment 4 Jens Petersen 2004-01-13 03:38:49 UTC
I would like to address this issue separately from bug 91233.

Comment 5 Jens Petersen 2004-01-13 03:41:56 UTC
Nevermind, fixed in FC Development in at-3.1.8-49.

Comment 6 Jens Petersen 2004-03-02 01:26:41 UTC
*** Bug 117102 has been marked as a duplicate of this bug. ***

Comment 7 Jens Petersen 2004-03-03 02:24:33 UTC
*** Bug 117276 has been marked as a duplicate of this bug. ***

Comment 8 John Flanagan 2004-12-21 21:19:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-593.html



Note You need to log in before you can comment on or make changes to this bug.