Bug 1133820 - distribute fails to heal grand parent quota xattrs
Summary: distribute fails to heal grand parent quota xattrs
Keywords:
Status: CLOSED DUPLICATE of bug 1306220
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-26 08:38 UTC by Harshavardhana
Modified: 2016-05-11 22:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-15 06:43:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Harshavardhana 2014-08-26 08:38:56 UTC
Description of problem:

Distribute fails to heal quota xattrs after add-brick and rebalance. 

Following change reveals the present issue

diff --git a/tests/basic/quota.t b/tests/basic/quota.t
index d5a95e2..7e01d8d 100755
--- a/tests/basic/quota.t
+++ b/tests/basic/quota.t
@@ -168,17 +168,17 @@ done
 # 65
 ## <Test whether quota limit crossed more than 10% of limit>
 ## ---------------------------------------------------------
-USED_KB=`du -s $M0/$TESTDIR/dir1 | cut -f1`;
+USED_KB=$(du -s $M0/$TESTDIR/dir1 | cut -f1);
 USED_MB=$(($USED_KB/1024));
 TEST [ $USED_MB -le $((($QUOTALIMIT * 110) / 100)) ]
 
 # 66-67
 ## <Test the xattrs healed to new brick>
 ## -------------------------------------
-TEST getfattr -d -m "trusted.glusterfs.quota.limit-set" -e hex \
+TEST getfattr -n trusted.glusterfs.quota.limit-set -e hex \
               --absolute-names $B0/brick{3,4}/$TESTDIR/dir{1..10};
 # Test on root.
-TEST getfattr -d -m "trusted.glusterfs.quota.limit-set" -e hex \
+TEST getfattr -n trusted.glusterfs.quota.limit-set -e hex \
               --absolute-names $B0/brick{3,4};
 
 ## -------------------------------------------------

The real issue in the test case was it wasn't checking the attributes properly before so this issue seemed non-existent, when we add the proper checks - we do see that the "root" or the top-level brick doesn't properly carry the quota attributes from its neighboring bricks. 

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Modify the quota.t test case shown above, it is reproducible consistently.

Comment 2 Vijaikumar Mallikarjuna 2016-02-15 06:43:54 UTC
This issue is same as bug# 1306220 and the patch has been submitted upstream: http://review.gluster.org/#/c/13422/

*** This bug has been marked as a duplicate of bug 1306220 ***


Note You need to log in before you can comment on or make changes to this bug.