Bug 1306220 - quota: xattr trusted.glusterfs.quota.limit-objects not healed on a root of newly added brick
Summary: quota: xattr trusted.glusterfs.quota.limit-objects not healed on a root of ne...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
: 1133820 (view as bug list)
Depends On: 1306218
Blocks: 1312954
TreeView+ depends on / blocked
 
Reported: 2016-02-10 10:59 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:57 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1306218
: 1312954 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:57:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-02-10 11:00:11 UTC
REVIEW: http://review.gluster.org/13422 (quota: heal object-limit on a root dir of a newly added brick) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijaikumar Mallikarjuna 2016-02-15 06:43:54 UTC
*** Bug 1133820 has been marked as a duplicate of this bug. ***

Comment 3 Vijay Bellur 2016-02-28 05:30:45 UTC
COMMIT: http://review.gluster.org/13422 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 15602865865386672bcb996dab8259d25b684900
Author: vmallika <vmallika@redhat.com>
Date:   Wed Feb 10 16:27:05 2016 +0530

    quota: heal object-limit on a root dir of a newly added brick
    
    When a new brick is added, xattr trusted.glusterfs.quota.limit-objects
    is not healed on a root directory.
    This patch will fix the problem
    
    Change-Id: I776609ebf4d7822c541b6262e63d465ea3a86db4
    BUG: 1306220
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13422
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 6 Niels de Vos 2016-06-16 13:57:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.