Bug 1134846 - java.lang.Exception while creating bundle using recipe file
Summary: java.lang.Exception while creating bundle using recipe file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ER02
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Depends On:
Blocks: 1050014
TreeView+ depends on / blocked
 
Reported: 2014-08-28 10:42 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:00:51 UTC
Type: Bug


Attachments (Terms of Use)
recipe_error (116.90 KB, application/octet-stream)
2014-08-28 10:43 UTC, Armine Hovsepyan
no flags Details
server.log (43.33 KB, text/plain)
2014-08-28 10:43 UTC, Armine Hovsepyan
no flags Details
recipe_file (1.16 KB, text/plain)
2014-08-28 10:44 UTC, Armine Hovsepyan
no flags Details
recipe_uploaded (112.84 KB, application/octet-stream)
2014-09-04 09:05 UTC, Armine Hovsepyan
no flags Details
bundle_files_upload_page (107.98 KB, application/octet-stream)
2014-09-04 09:06 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-08-28 10:42:43 UTC
Description of problem:
java.lang.Exception while creating bundle using recipe file

Version-Release number of selected component (if applicable):
Version : 3.3.0.ER01.1
Build Number : 9941660:f3aa7e7

How reproducible:
always

Steps to Reproduce:
1. Navigate to Bundles
2. Click on 'New' button
3. Click 'Recipe' radio button
4. Click 'Click to load recipe file' button
5. browse a recipe file and upload it
6. Click 'Next' button

Actual results:
[1409222361835] java.lang.Exception:The Wildfly patches cannot be dealt with using only recipes - the whole distribution file is needed -- on page

Expected results:
bundle recipe is uploaded, upload war page is visible

Additional info:
please get screen-shot, fragment from server.log and test.xml recipe file attached

Comment 1 Armine Hovsepyan 2014-08-28 10:43:39 UTC
Created attachment 931860 [details]
recipe_error

Comment 2 Armine Hovsepyan 2014-08-28 10:43:59 UTC
Created attachment 931861 [details]
server.log

Comment 3 Armine Hovsepyan 2014-08-28 10:44:20 UTC
Created attachment 931862 [details]
recipe_file

Comment 5 Lukas Krejci 2014-08-28 13:52:58 UTC
This is regression caused by BZ 1069547.

Fix in master:

commit fc231cc754aaf4aaa40545f96c3650920574e8e8
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Thu Aug 28 15:46:54 2014 +0200

    [BZ 1069547] Throw UnknownRecipeException instead of overly broad Exception
    from the WildflyPatchBundleServerPluginComponent#parseRecipe().

Comment 6 Lukas Krejci 2014-08-28 13:53:56 UTC
Fix in release/jon3.3.x:

commit 7cb3499a47ab3a46add5724cf0ebe9113b9f8ca3
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Thu Aug 28 15:46:54 2014 +0200

    [BZ 1069547] Throw UnknownRecipeException instead of overly broad Exception
    from the WildflyPatchBundleServerPluginComponent#parseRecipe().
    
    (cherry picked from commit fc231cc754aaf4aaa40545f96c3650920574e8e8)
    Signed-off-by: Lukas Krejci <lkrejci@redhat.com>

Comment 7 Simeon Pinder 2014-09-03 20:31:26 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194

Comment 8 Armine Hovsepyan 2014-09-04 09:04:31 UTC
verified in JON 3.3 ER02
screen-shots attached

Comment 9 Armine Hovsepyan 2014-09-04 09:05:09 UTC
Created attachment 934331 [details]
recipe_uploaded

Comment 10 Armine Hovsepyan 2014-09-04 09:06:02 UTC
Created attachment 934332 [details]
bundle_files_upload_page


Note You need to log in before you can comment on or make changes to this bug.