Bug 1050014 - Cannot deploy bundle to EAP domain mode
Summary: Cannot deploy bundle to EAP domain mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER04
: JON 3.3.0
Assignee: Thomas Segismont
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
: 847049 (view as bug list)
Depends On: 1067021 1134486 1134846 1135551 1139607 1139684 1139767
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-08 15:46 UTC by Bill DeCoste
Modified: 2018-11-28 19:33 UTC (History)
8 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:00:06 UTC
Type: Enhancement


Attachments (Terms of Use)
bz_1050014_create_servergroup.png (38.45 KB, image/png)
2014-08-08 08:33 UTC, Garik Khachikyan
no flags Details
bz_1050014_create_servergroup_step2.png (43.98 KB, image/png)
2014-08-08 08:34 UTC, Garik Khachikyan
no flags Details
bz_1050014_servergroup.png (37.26 KB, image/png)
2014-08-08 08:35 UTC, Garik Khachikyan
no flags Details
bz_1050014_deploymentFails.png (127.38 KB, image/png)
2014-08-08 08:36 UTC, Garik Khachikyan
no flags Details
bundle_depl_domain (217.77 KB, application/octet-stream)
2014-08-27 13:52 UTC, Armine Hovsepyan
no flags Details
domain_delp (156.95 KB, application/octet-stream)
2014-09-17 12:23 UTC, Armine Hovsepyan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 301573 None None None 2018-11-28 19:33:01 UTC
JBoss Issue Tracker JON3-7 Critical Verified Support bundles / drift on EAP6 domain mode 2017-08-15 17:10:42 UTC
Red Hat Bugzilla 1069547 None None None Never
Red Hat Bugzilla 1069646 None None None Never
Red Hat Bugzilla 1070254 None None None Never
Red Hat Bugzilla 1070326 None None None Never

Internal Links: 1069547 1069646 1070254 1070326

Description Bill DeCoste 2014-01-08 15:46:59 UTC
Description of problem:
Cannot deploy a bundle to domain mode. Groups of Host Controller or Managed Servers do not appear in bundle deployment dropdown


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Spin up EAP in domain mode
2. Create Group of Host Controllers and Group of Managed Servers
3. Add and try to deploy a bundle

Actual results:
Neither Group shows up in dropdown

Expected results:
At least one of the groups should show up

Additional info:

Comment 2 Lukas Krejci 2014-05-21 17:37:06 UTC
*** Bug 847049 has been marked as a duplicate of this bug. ***

Comment 3 Lukas Krejci 2014-05-21 17:38:34 UTC
See BZ 847049 for some more discussion of the possible implementation approaches.

Comment 4 Thomas Segismont 2014-07-04 14:25:40 UTC
Fixed in master

commit ad48260579effc8b5eea2e059895d8b4534352c7
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Jul 3 10:19:20 2014 +0200

Comment 5 JBoss JIRA Server 2014-07-07 09:35:20 UTC
Heiko Rupp <hrupp@redhat.com> updated the status of jira JON3-7 to Resolved

Comment 6 Thomas Segismont 2014-07-24 14:10:16 UTC
Additional commit to master

commit cede4b6da948a3218b55316166fd6fba049b008b
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Jul 24 16:06:57 2014 +0200

Deployment node must be created with the filename, not the runtime name
    
See also Bug 1119781 - runtime name provided for deployment child creation overrides application name and path

Comment 7 Thomas Segismont 2014-07-24 14:11:58 UTC
(In reply to Thomas Segismont from comment #6)
> Additional commit to master
> 
> commit cede4b6da948a3218b55316166fd6fba049b008b
> Author: Thomas Segismont <tsegismo@redhat.com>
> Date:   Thu Jul 24 16:06:57 2014 +0200
> 
> Deployment node must be created with the filename, not the runtime name
>     
> See also Bug 1119781 - runtime name provided for deployment child creation
> overrides application name and path

Cherry-picked over to release/jon3.3.x

commit 4afff8009c59cb1924180d5a237523f1b3d3b63b
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Jul 24 16:09:23 2014 +0200

Comment 8 Simeon Pinder 2014-07-31 15:52:11 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Comment 9 Garik Khachikyan 2014-08-04 11:52:54 UTC
JON3-7 task. taking QA contact

Comment 11 Garik Khachikyan 2014-08-08 05:16:05 UTC
sorry, please. I move it back to ON_QA status - I actually missed the point - it's need to be checked for EAP6 _domain_ servers (I did making for Standalone ones).

Comment 12 Garik Khachikyan 2014-08-08 08:33:05 UTC
REOPEN

But there is an issue however even trying on EAP6 Domain Controllers:

Steps to reproduce:
1. create a bundle (could be used the same in the comment#10.
2. make a system group from a EAP6 Domain agent (see attachments):
  2.1. create group step 1 - bz_1050014_create_servergroup.png
  2.2. choose the EAP6 Domain Controller resource (with recoursive checkbox selected) - bz_1050014_create_servergroup_step2.png
  2.3 see the result - bz_1050014_servergroup.png
3. Try to deploy the bundle to that server group - failing
  3.1. see attachment - bz_1050014_deploymentFails.png

logs:
agent.log
===
2014-08-08 03:42:10,586 ERROR [ResourceContainer.invoker.nonDaemon-7] (org.rhq.plugins.ant.AntBundlePluginComponent)- Failed to deploy bundle [class org.rhq.core.pluginapi.bundle.BundleDeployRequest: deployment=[BundleResourceDeployment: bdd=[BundleDeployment[id=10012, name=Deployment [1] of Version [1.0] to [jon]]], resource=[Resource[id=12998, uuid=4a125223-a673-4ebb-bfe8-5db65532bfb6, type={JBossAS7}JBossAS7 Host Controller, key=hostConfig: /root/jboss-eap-6.0/domain/configuration/host.xml, name=EAP Domain Controller (master 0.0.0.0:8990), version=EAP 6.0.0.GA]]], full-deploy-directory=[/root/jboss-eap-6.0/domain/tmp/.], clean=[true], revert=[false]]
java.lang.Exception: Failed to execute the bundle Ant script
        at org.rhq.plugins.ant.AntBundlePluginComponent.deployBundle(AntBundlePluginComponent.java:168)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocation.call(ResourceContainer.java:759)
        at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.RuntimeException: Failed to execute bundle deploy file [/root/rhq-agent/data/tmp/bundle-versions/10035/ant-bundle-recipe2643464848411448197.xml]. Cause: /root/rhq-agent/data/tmp/bundle-versions/10035/ant-bundle-recipe2643464848411448197.xml:6: Failed to deploy bundle [Jenkins build (Linux)] version [1.0]: java.lang.Exception: Handover failed: Handover[action='deployment', handoverParams=[antlib:org.rhq.bundle:handover-param [name='runtimeName', value='jenkins.war'], antlib:org.rhq.bundle:handover-param [name='serverGroup', value='jon-mercury']], failOnError=true]
        at org.rhq.bundle.ant.AntLauncher.executeBundleDeployFile(AntLauncher.java:154)
        at org.rhq.plugins.ant.AntBundlePluginComponent.executeDeploymentPhase(AntBundlePluginComponent.java:324)
        at org.rhq.plugins.ant.AntBundlePluginComponent.deployBundle(AntBundlePluginComponent.java:148)
        ... 9 more
Caused by: /root/rhq-agent/data/tmp/bundle-versions/10035/ant-bundle-recipe2643464848411448197.xml:6: Failed to deploy bundle [Jenkins build (Linux)] version [1.0]: java.lang.Exception: Handover failed: Handover[action='deployment', handoverParams=[antlib:org.rhq.bundle:handover-param [name='runtimeName', value='jenkins.war'], antlib:org.rhq.bundle:handover-param [name='serverGroup', value='jon-mercury']], failOnError=true]
        at org.rhq.bundle.ant.type.DeploymentUnitType.install(DeploymentUnitType.java:300)
        at org.rhq.bundle.ant.type.DeploymentUnitType.upgrade(DeploymentUnitType.java:532)
        at org.rhq.bundle.ant.task.BundleTask.execute(BundleTask.java:170)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:390)
        at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:179)
        at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:80)
        at org.rhq.bundle.ant.AntLauncher.executeBundleDeployFile(AntLauncher.java:150)
        ... 11 more
Caused by: java.lang.Exception: Handover failed: Handover[action='deployment', handoverParams=[antlib:org.rhq.bundle:handover-param [name='runtimeName', value='jenkins.war'], antlib:org.rhq.bundle:handover-param [name='serverGroup', value='jon-mercury']], failOnError=true]
        at org.rhq.bundle.ant.type.DeploymentUnitType.install(DeploymentUnitType.java:274)
        ... 24 more
===

Comment 13 Garik Khachikyan 2014-08-08 08:33:58 UTC
Created attachment 925120 [details]
bz_1050014_create_servergroup.png

Comment 14 Garik Khachikyan 2014-08-08 08:34:51 UTC
Created attachment 925121 [details]
bz_1050014_create_servergroup_step2.png

Comment 15 Garik Khachikyan 2014-08-08 08:35:41 UTC
Created attachment 925122 [details]
bz_1050014_servergroup.png

Comment 16 Garik Khachikyan 2014-08-08 08:36:16 UTC
Created attachment 925123 [details]
bz_1050014_deploymentFails.png

Comment 17 JBoss JIRA Server 2014-08-15 22:38:18 UTC
mfoley user <mfoley@redhat.com> updated the status of jira JON3-7 to Reopened

Comment 18 Thomas Segismont 2014-08-19 09:35:39 UTC
I had a look at the screenshots and to me, it looks like you made a confusion between the JON resource group and the EAP 6 domain server group.

The JON resource group is part of the bundle target and is chosen when creating the bundle destination.

The EAP 6 server group is the name of the group of logical servers you want to deploy the application to. It has the value of the "serverGroup" handover parameter and is chosen when deploying the bundle. A default value may come from the bundle recipe.

Comment 19 Garik Khachikyan 2014-08-19 10:02:01 UTC
# ON_QA

after discussion with Thomas S. got the confusion which I made: following are two different things: resource group and the EAP6 domain server group (this is what I should be providing in serverGroup parameter).
---
<tsegismont> open Inventory > Child resources subtab and then Create Child > Server group
<tsegismont> you must not confuse an EAP Domain Server group
<tsegismont> and a JON resource group
<tsegismont> These are two different concepts
---

Comment 20 Mike Foley 2014-08-25 17:16:36 UTC
test documentation

https://tcms.engineering.redhat.com/run/169471/?from_plan=14599

qe owner - garik

Comment 21 Armine Hovsepyan 2014-08-27 13:52:10 UTC
Created attachment 931488 [details]
bundle_depl_domain

Comment 23 Armine Hovsepyan 2014-08-27 13:54:23 UTC
moving back to ON_QA until https://tcms.engineering.redhat.com/run/169471/?from_plan=14599 TCMS test run is finished

Comment 27 Thomas Segismont 2014-09-12 14:35:14 UTC
Back to MODIFIED, all blockers at MODIFIED or VERIFIED level

Comment 28 Simeon Pinder 2014-09-17 02:49:04 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149

Comment 29 Armine Hovsepyan 2014-09-17 12:23:27 UTC
Created attachment 938451 [details]
domain_delp

Comment 30 Armine Hovsepyan 2014-09-19 13:45:47 UTC
changing target release to ER04, to close with #1139684

Comment 31 Armine Hovsepyan 2014-10-06 14:33:10 UTC
all blocking BZs verified - moving to verified state
thank you

Comment 32 JBoss JIRA Server 2014-10-22 17:06:10 UTC
mfoley user <mfoley@redhat.com> updated the status of jira JON3-7 to Resolved


Note You need to log in before you can comment on or make changes to this bug.