Bug 1134882 - perl-MongoDB-0.702.2-4.fc22 FTBFS: t/gridfs.t tests fails
Summary: perl-MongoDB-0.702.2-4.fc22 FTBFS: t/gridfs.t tests fails
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-MongoDB
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
: 1239777 (view as bug list)
Depends On: 855072
Blocks: F23FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-08-28 12:02 UTC by Petr Pisar
Modified: 2015-09-04 07:07 UTC (History)
11 users (show)

Fixed In Version: 0.708.4.0-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-04 03:22:58 UTC
Type: Bug


Attachments (Terms of Use)
build.log (89.88 KB, text/plain)
2014-08-28 12:02 UTC, Petr Pisar
no flags Details
Build log against Perl 5.22 (15.17 KB, text/plain)
2015-06-12 13:39 UTC, Jitka Plesnikova
no flags Details

Description Petr Pisar 2014-08-28 12:02:44 UTC
Created attachment 931912 [details]
build.log

+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t t/threads/*.t
t/bson.t ............ ok
t/collection.t ...... ok
t/connection.t ...... ok
t/cursor.t .......... ok
t/database.t ........ ok
t/db.t .............. ok
t/dbref.t ........... ok
t/delegation.t ...... ok
t/dt_types.t ........ ok
t/fsync.t ........... ok
recieve an unexpected error from the server: exception: Can't get runner for query { files_id: ObjectId('53ff0c873f30e15152000000'), n: { $gte: 0 } } at /builddir/build/BUILD/MongoDB-0
.702.2/blib/lib/MongoDB/GridFS.pm line 236.
# Looks like you planned 62 tests but ran 4.
# Looks like your test exited with 255 just after 4.
t/gridfs.t .......... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 58/62 subtests 
t/regex.t ........... ok
t/threads/basic.t ... ok
t/threads/cursor.t .. ok
t/threads/oid.t ..... ok
t/types.t ........... ok
t/w.t ............... ok
Test Summary Report
-------------------
t/gridfs.t        (Wstat: 65280 Tests: 4 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 62 tests but ran 4.
Files=17, Tests=522, 29 wallclock secs ( 0.11 usr  0.03 sys + 10.60 cusr  0.80 csys = 11.54 CPU)
Result: FAIL

Comment 1 Petr Pisar 2014-08-29 11:14:27 UTC
The difference between last working and this buildroot is:

Removed packages:
	audit-libs-2.3.8
	bash-4.3.22
	boost-iostreams-1.55.0
	krb5-devel-1.12.2
	krb5-libs-1.12.2
	libicu-52.1
	libtasn1-4.0
	mongodb-server-2.4.9
	nss-3.16.2
	nss-softokn-3.16.2
	nss-softokn-freebl-3.16.2
	nss-sysinit-3.16.2
	nss-tools-3.16.2
	nss-util-3.16.2
	p11-kit-0.20.3
	p11-kit-trust-0.20.3
	perl-HTTP-Tiny-0.047
	perl-Module-Build-0.42.06
	perl-Module-Install-1.06
	perl-Module-ScanDeps-1.14
	perl-Pod-Perldoc-3.23
	perl-version-0.99.08
	setup-2.9.1
	sqlite-3.8.5
	systemd-215
	systemd-libs-215
Added packages:
	audit-libs-2.4
	bash-4.3.24
	krb5-devel-1.13
	krb5-libs-1.13
	libicu-53.1
	libtasn1-4.1
	mongodb-server-2.6.3
	nss-3.17.0
	nss-softokn-3.17.0
	nss-softokn-freebl-3.17.0
	nss-sysinit-3.17.0
	nss-tools-3.17.0
	nss-util-3.17.0
	p11-kit-0.21.1
	p11-kit-trust-0.21.1
	perl-HTTP-Tiny-0.048
	perl-Module-Build-0.42.08
	perl-Module-Install-1.10
	perl-Module-ScanDeps-1.15
	perl-Pod-Perldoc-3.24
	perl-version-0.99.09
	setup-2.9.2
	sqlite-3.8.6
	systemd-216
	systemd-libs-216

Comment 2 Robin Lee 2014-09-13 15:00:16 UTC
Forwarded upstream by now
https://jira.mongodb.org/browse/PERL-432

Comment 3 Petr Pisar 2014-11-28 09:41:18 UTC
Upstream closed the report because the version was too old. Latest upstream version is v0.707.0.0.

Comment 4 Jaroslav Reznik 2015-03-03 16:15:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 5 Jitka Plesnikova 2015-06-12 13:39:07 UTC
All tests of build perl-MongoDB-0.702.2-6.fc23 against Perl 5.22 failed with following error:

machine id required at /usr/lib64/perl5/DynaLoader.pm line 216.
Compilation failed in require at t/bson.t line 24.
BEGIN failed--compilation aborted at t/bson.t line 24.
t/bson.t ............

Comment 6 Jitka Plesnikova 2015-06-12 13:39:46 UTC
Created attachment 1038081 [details]
Build log against Perl 5.22

Comment 7 Adam Williamson 2015-08-05 07:25:29 UTC
This is now an Alpha blocker, as perl-MongoDB is on the Server DVD and its dependencies are broken:

https://fedorahosted.org/rel-eng/ticket/6213#comment:7

Marking as an automatic blocker per policy: "Unresolved dependencies on a release-blocking DVD-style (offline installer) image (failures of QA:Testcase_Mediakit_Repoclosure)" - https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers

Comment 8 Petr Pisar 2015-08-05 07:50:23 UTC
I have no idea why perl-MongoDB is on the Server DVD while the package delivers clients only. But I lost hope the package will be fixed soon. I can review the latest upstream releases again.

Current status is no participating upstreams are not willing to stop bundling or are unresponsive. And Fedora maintainers are no willing to merge non-upstreamed enhancements. Therefore there no way how to fix it.

Comment 9 Petr Pisar 2015-08-05 07:54:01 UTC
The reason why this package does not build is it does not pass tests with current mongodb server.

Comment 10 Petr Pisar 2015-08-05 08:18:27 UTC
I checked latest upstream sources.

Latest stable perl's MongoDB-v0.708.3.0 still bundles libbson which uses internals of bundled yajl.

Latest development libbson sources still use internals of bundled yajl.

Development yajl sources have not changed since the last time. The proposed patch was not merged, neither responded.

Comment 11 Petr Pisar 2015-08-05 08:20:21 UTC
*** Bug 1239777 has been marked as a duplicate of this bug. ***

Comment 12 Adam Williamson 2015-08-05 10:18:51 UTC
So it's coming into the Server DVD through one of the questionable groups in the fedora-install-server.ks kickstart:

# Web Server environment
@haproxy
@mongodb
@perl-web
@python-web
@php
@rubyonrails
@tomcat

It's part of that '@perl-web' group. We should probably just drop all/some of that crap, finally - we do keep talking about it. CCing sgallagh. If we drop this from the Server kickstart that constitutes resolving it as a blocker (but of course doesn't fix the FTBFS).

Comment 13 Petr Pisar 2015-08-05 10:47:50 UTC
I removed perl-MongoDB from the perl-web group for F23 and F24. It can be added back when the package gets healthy.

Once you verify it, you can remove this bug report from AlphaBlocker/F23AlphaBlocker list.

Comment 14 Stephen Gallagher 2015-08-05 12:49:43 UTC
Due to a peculiarity in the compose system, this won't be enough to let us cut an RC2 today (we would have to wait until tomorrow for comps.xml to be regenerated). As a temporary measure, I've just removed[1] the @perl-web group from the Server DVD definition for Alpha (since it provides no packages that we block on for the release). I'll re-add it immediately after RC2 is cut.

[1] https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f23&id=1568248565294e3036e1f7f1a4f7398d38120fd3

Comment 15 Stephen Gallagher 2015-08-05 13:22:47 UTC
Moving this to ON_QA to be verified in RC2

Comment 16 Adam Williamson 2015-08-07 16:56:59 UTC
Per https://fedorahosted.org/rel-eng/ticket/6213#comment:9 , RC2 repoclosure is good, so that means we can drop this bug's blocker status. The bug is still a bug, though, so not closing.

Comment 17 Ken Dreyer 2015-08-07 17:30:06 UTC
I see Robin (FAS cheeselee) recently removed himself from this package in pkgdb, and since I have switched jobs and I no longer use this package @ work, I'm going to do the same. That means the package will be orphaned.

Comment 18 Petr Šabata 2015-08-12 12:02:24 UTC
The latest version, v0.708.4.0, builds and seems to work correctly.
YAJL bundling is still an issue but that's another problem.

Should this be added back to the perl-web group?

Comment 19 Adam Williamson 2015-08-13 13:27:26 UTC
Sure, removing it was just a temporary workaround.

Comment 20 Fedora Update System 2015-09-02 06:41:29 UTC
perl-MongoDB-0.708.4.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14817

Comment 21 Petr Pisar 2015-09-02 06:56:22 UTC
When can we readd the perl-MongoDB in the perl-web group? After the build gets into stable repository?

Comment 22 Fedora Update System 2015-09-03 09:53:09 UTC
perl-MongoDB-0.708.4.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update perl-MongoDB'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14817

Comment 23 Fedora Update System 2015-09-04 03:22:56 UTC
perl-MongoDB-0.708.4.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Petr Pisar 2015-09-04 07:07:19 UTC
I added perl-MongoDB package back to perl-web group in F23 and F24.


Note You need to log in before you can comment on or make changes to this bug.