Bug 1135099 - Should send data message for file copy of 0 size
Summary: Should send data message for file copy of 0 size
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On: 1185434
Blocks: 1135104 1135105
TreeView+ depends on / blocked
 
Reported: 2014-08-28 19:55 UTC by Marc-Andre Lureau
Modified: 2015-07-22 06:31 UTC (History)
5 users (show)

Fixed In Version: spice-gtk-0.26-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: missing SPICE protocol message when dragging 0-byte file from client to guest Consequence: resource leak on the guest (file descriptor) Fix: make sure the expected SPICE message is sent to the guest even for 0-byte files Result: no more resource leak
Clone Of:
: 1135104 1135105 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:31:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1322 0 normal SHIPPED_LIVE virt-viewer and spice-gtk bug fix and enhancement update 2015-07-20 17:53:14 UTC

Description Marc-Andre Lureau 2014-08-28 19:55:56 UTC
Description of problem:

spice-gtk doesn't send data message for 0-size files, however both linux and windows agents are expecting to receive it, or they will keep a file open, thus leaking it.

Version-Release number of selected component (if applicable):

any with file copy/xfer support

How reproducible:

100%

Steps to Reproduce:
1. dnd 0-size files to remote desktop

Actual results:

spice-vdagent number of open fd keeps growing

Expected results:

number of fd shouldn't grow.

Comment 7 errata-xmlrpc 2015-07-22 06:31:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html


Note You need to log in before you can comment on or make changes to this bug.