Bug 1135105 - Should send data message for file copy of 0 size
Summary: Should send data message for file copy of 0 size
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Default Assignee for SPICE Bugs
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On: 1135099 1181289
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-28 20:07 UTC by Marc-Andre Lureau
Modified: 2016-03-09 20:08 UTC (History)
15 users (show)

Fixed In Version: mingw-virt-viewer-2.0-1.el7ev
Doc Type: Bug Fix
Doc Text:
Previously, the SPICE client did not send a data message when transferring zero-sized files by drag and drop. Because the guest agent expects to receive a message, it would keep a file open, causing a leak. This has been fixed by adding a transfer message for zero-sized files to prevent guests from leaking file descriptors in the guest agent during the copy.
Clone Of: 1135099
Environment:
Last Closed: 2016-03-09 20:08:59 UTC
oVirt Team: Spice
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0377 0 normal SHIPPED_LIVE rhevm-spice-client bug fix and enhancement update 2016-03-10 00:39:05 UTC

Description Marc-Andre Lureau 2014-08-28 20:07:51 UTC
+++ This bug was initially created as a clone of Bug #1135099 +++

Description of problem:

spice-gtk doesn't send data message for 0-size files, however both linux and windows agents are expecting to receive it, or they will keep a file open, thus leaking it.

Version-Release number of selected component (if applicable):

any with file copy/xfer support

How reproducible:

100%

Steps to Reproduce:
1. dnd 0-size files to remote desktop

Actual results:

spice-vdagent number of open fd keeps growing

Expected results:

number of fd shouldn't grow.

Comment 3 David Jaša 2015-07-23 10:52:54 UTC
Well-known problem, qa_ack+

Comment 6 Dayle Parker 2016-03-01 00:39:09 UTC
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

 Cause:
 Consequence:
 Fix:
 Result:

Comment 7 Tomas Pelka 2016-03-01 09:28:11 UTC
I'm sorry Dayle, we as QE are not responsible for filling doc text.

Comment 9 errata-xmlrpc 2016-03-09 20:08:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0377.html


Note You need to log in before you can comment on or make changes to this bug.