Bug 1135324 - [doc] Need section for Satellite 6 upgrade instructions
Summary: [doc] Need section for Satellite 6 upgrade instructions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: Unspecified
Assignee: David O'Brien
QA Contact: Peter Ondrejka
URL:
Whiteboard:
: 1195842 1227785 (view as bug list)
Depends On: 1221174 1227785 1228375
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 1195450
TreeView+ depends on / blocked
 
Reported: 2014-08-29 05:24 UTC by Xixi
Modified: 2019-09-26 16:28 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-24 00:32:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1169393 None None None Never
Red Hat Bugzilla 1195842 None None None Never

Internal Links: 1195842

Description Xixi 2014-08-29 05:24:49 UTC
Description of problem:
Satellite 6.x->6.y upgrade is significantly different than Satellite 5.x->5.y, this BZ is to track need for upgrade documentation (not GA but for Satellite 6.1 of course :)).

Version-Release number of selected component (if applicable):
6.0.3

How reproducible:
always

Steps to Reproduce:
1. (see above)
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2014-08-29 05:42:53 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Athene Chan 2014-08-31 22:14:04 UTC
Adding to list of 6.1 sections :)

Comment 8 Ivan Necas 2014-12-16 13:02:37 UTC
Redirecting to stbenjam as he has probably more fresh info than I do

Comment 9 Stephen Benjamin 2015-02-13 22:04:07 UTC
Hi,

The upgrade instructions for upstream will be very similar for Satellite 6.1:
  http://www.katello.org/docs/2.1/upgrade/index.html

I will leave the needinfo as there may be further instructions for upgrade to isolated capsule.

Comment 12 Lukas Zapletal 2015-02-17 11:43:31 UTC
Upgrade step for Discovery plugin:

In the Satellite 6 user interface, go to Provisioning Templates, edit the PXELinux global default template and modify the discovery menu entry:

LABEL discovery
MENU LABEL Foreman Discovery
MENU DEFAULT
KERNEL /var/lib/tftpboot/boot/fdi-image-rhel_7-vmlinuz
APPEND initrd=boot/fdi-image-rhel_7-img rootflags=loop root=live:/fdi.iso rootfstype=auto ro rd.live.image acpi=force rd.luks=0 rd.md=0 rd.dm=0 rd.lvm=0 rd.bootif=0 rd.neednet=0 nomodeset proxy.url=https://SATELLITE_CAPSULE_URL proxy.type=proxy
IPAPPEND 2

The proxy.type option can be either proxy or foreman. In the first case all communication goes through Satellite Capsule, in the latter case the communication goes directly to Satellite Server (behavior of Satellite 6.0 release).

The proxy.url specifies URL of the Satellite Capsule or Server depending on the previous setting. Both http and https schemes are supported.

On the TFTP Satellite Capsule, install the following package which has been added in Satellite 6.1 if you plan to leverage Capsule as a proxy for discovered hosts (so no direct connection to Satellite Server is required):

yum install rubygem-smart_proxy_discovery.noarch

Check if foreman_url setting is present on the Capsule pointing to the Satellite Server correctly:

grep foreman_url /etc/foreman-proxy/settings.yml 
:foreman_url: https://fqdn.of.satellite.server.host

Then restart the foreman-proxy component on the Satellite Capsule server:

service foreman-proxy restart

Upgrade foreman-discovery-image package on the Satellite Server and reboot all discovered nodes via Satellite user interface or CLI.

Comment 15 RHEL Product and Program Management 2015-04-21 16:10:37 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 19 David O'Brien 2015-06-12 06:31:49 UTC
Stephen,
Can I get you to go over this? I'm not in any position to test upgrades, and for beta I'm quite happy to take Tahlia's edits as-is. We're supposed to be freezing all the docs for beta inside the next 24 hours.

thanks a lot

Comment 20 Stephen Benjamin 2015-06-12 13:14:30 UTC
Hi David,

No problem. Overall it looks good and correct, it seems to be based off the latest version of the notes we had in the upgrade pad, so no major issues.

A few comments:


Section 7:

"The Satellite Server and Capsule Servers are upgraded independently. Upgrade the Satellite server first, and then upgrade any Capsules."

Add a note that 6.0 capsules are not compatible with 6.1, and need to be upgraded.

Section 7.2:

I would swap steps 7 & 8, as copying the answer file is needed because of the note before step 7.

Step 9 - maybe add "If this capsule will be used for discovery, "

Step 9 b, c, and d should be removed.  (b) will be fixed by the installer upgrade if its wrong, (c) is going to happen during the upgrade, and (d) was a prerequisite to begin the upgrade.

Comment 21 Stephen Benjamin 2015-06-12 13:22:24 UTC
Oh one more! We should take BZ1221217 into account!

If users have made manual edits to configuration files controlled by Satellite, they should understand they will get overwritten.  There's an explanation in comment 1 of the first BZ.

The most common changes people may have made is to the DHCP and DNS configuration and might be surprised when that gets overwritten.  If they do not want this to happen, they should add these options to the --upgrade installer command:

on Katello:
--capsule-dns-managed=false --capsule-dhcp-managed=false

on Capsule:
--dns-managed=false --dhcp-managed=false

This will leave their DNS and DHCP configruations untouched forever, until they set managed=true again.

Comment 22 Tahlia Richardson 2015-06-15 04:16:12 UTC
Thanks Stephen! I'll include these items in my next pass at the chapter. I'm too late for beta, but I'll have this all done for GA.

Comment 26 Tahlia Richardson 2015-06-22 01:23:42 UTC
*** Bug 1227785 has been marked as a duplicate of this bug. ***

Comment 30 David O'Brien 2015-07-23 06:32:45 UTC
Can't verify this because there are still missing bits.

Tahlia,
We might have to get together and work this out, unless you want to review https://bugzilla.redhat.com/show_bug.cgi?id=1195842 and Lukas' etherpad notes?

Apparently a couple of bits in the Discovery upgrade need another look.

We might need to sort out what's going in the rel notes as well.

Comment 34 Stephen Benjamin 2015-07-29 14:24:03 UTC
Just 2 notes, but looks otherwise accurate although a little cumbersome.


* I don't see how step 1 is possible, does 6.0.8 include /usr/bin/katello-backup?
I don't think it does. 

* Step 3, and 4.  Can you refactor this like the install guide so you show cut-and-paste commands for rhel 6 AND 7?

See: section 2.1.1, #4 http://file.bne.redhat.com/~daobrien/Satellite6.1/Installation_Guide/#sect-Red_Hat_Satellite-Installation_Guide-Downloading_from_a_Connected_Network

Comment 35 Stephen Benjamin 2015-07-31 11:52:34 UTC
Sorry for the delay about the discovery stuff -

For the Discovery Upgrade in the release notes (http://file.bne.redhat.com/~daobrien/Satellite6.1/Release_Notes/#sect-Red_Hat_Satellite-Release_Notes-Product_Notes-Upgrading_the_Discovery_Feature), I think you can actually leave it as is - include it in the Capsule upgrade, but as a separate section, and you should be fine.

Comment 36 David O'Brien 2015-08-04 01:42:05 UTC
Re Comment 34: Step 1 is not possible but we need to work out a suitable replacement for "back up the databases". I emailed mmccune and stbenjamin about this.

Steps 3 & 4 have been refactored as requested.

Re Comment 35: the Discovery Upgrade section has been moved from the Release Notes to a separate section after "Upgrading Satellite Capsule".

Setting need_info for Stephen to work out the database backup step.

Comment 37 David O'Brien 2015-08-04 01:47:01 UTC
*** Bug 1195842 has been marked as a duplicate of this bug. ***

Comment 39 David O'Brien 2015-08-04 05:27:09 UTC
Have everything we need for now, I think. Remove need-info


Note You need to log in before you can comment on or make changes to this bug.